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Preface

This book is aimed at the reader who wishes to gain a working knowledge of time
series and forecasting methods as applied in economics, engineering and the natural
and social sciences. Unlike our earlier book, Time Series: Theory and Methods, re-
ferred to in the text as TSTM, this one requires only a knowledge of basic calculus,
matrix algebra and elementary statistics at the level (for example) of Mendenhall,
Wackerly and Scheaffer (1990). It is intended for upper-level undergraduate students
and beginning graduate students.

The emphasis is on methods and the analysis of data sets. The student version
of the time series package ITSM2000, enabling the reader to reproduce most of the
calculations in the text (and to analyze further data sets of the reader’s own choosing),
is included on the CD-ROM which accompanies the book. The data sets used in the
book are also included. The package requires an IBM-compatible PC operating under
Windows 95, NT version 4.0, or a later version of either of these operating systems.
The program ITSM can be run directly from the CD-ROM or installed on a hard disk
as described at the beginning of Appendix D, where a detailed introduction to the
package is provided.

Very little prior familiarity with computing is required in order to use the computer
package. Detailed instructions for its use are found in the on-line help files which
are accessed, when the program ITSM is running, by selecting the menu option
Help>Contents and selecting the topic of interest. Under the heading Data you
will find information concerning the data sets stored on the CD-ROM. The book can
also be used in conjunction with other computer packages for handling time series.
Chapter 14 of the book by Venables and Ripley (1994) describes how to perform
many of the calculations using S-plus.

There are numerous problems at the end of each chapter, many of which involve
use of the programs to study the data sets provided.

To make the underlying theory accessible to a wider audience, we have stated
some of the key mathematical results without proof, but have attempted to ensure
that the logical structure of the development is otherwise complete. (References to
proofs are provided for the interested reader.)
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Since the upgrade to ITSM2000 occurred after the first edition of this book
appeared, we have taken the opportunity, in this edition, to coordinate the text with
the new software, to make a number of corrections pointed out by readers of the first
edition and to expand on several of the topics treated only briefly in the first edition.

Appendix D, the software tutorial, has been rewritten in order to be compatible
with the new version of the software.

Some of the other extensive changes occur in (i) Section 6.6, which highlights
the role of the innovations algorithm in generalized least squares and maximum
likelihood estimation of regression models with time series errors, (ii) Section 6.4,
where the treatment of forecast functions for ARIMA processes has been expanded
and (iii) Section 10.3, which now includes GARCH modeling and simulation, topics
of considerable importance in the analysis of financial time series. The new material
has been incorporated into the accompanying software, to which we have also added
the option Autofit. This streamlines the modeling of time series data by fitting
maximum likelihood ARMA(p, q) models for a specified range of (p, q) values and
automatically selecting the model with smallest AICC value.

There is sufficient material here for a full-year introduction to univariate and mul-
tivariate time series and forecasting. Chapters 1 through 6 have been used for several
years in introductory one-semester courses in univariate time series at Colorado State
University and Royal Melbourne Institute of Technology. The chapter on spectral
analysis can be excluded without loss of continuity by readers who are so inclined.

We are greatly indebted to the readers of the first edition and especially to Matthew
Calder, coauthor of the new computer package, and Anthony Brockwell for their
many valuable comments and suggestions. We also wish to thank Colorado State
University, the National Science Foundation, Springer-Verlag and our families for
their continuing support during the preparation of this second edition.

Fort Collins, Colorado Peter J. Brockwell
August 2001 Richard A. Davis
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1 Introduction

1.1 Examples of Time Series
1.2 Objectives of Time Series Analysis
1.3 Some Simple Time Series Models
1.4 Stationary Models and the Autocorrelation Function
1.5 Estimation and Elimination of Trend and Seasonal Components
1.6 Testing the Estimated Noise Sequence

In this chapter we introduce some basic ideas of time series analysis and stochastic
processes. Of particular importance are the concepts of stationarity and the autocovari-
ance and sample autocovariance functions. Some standard techniques are described
for the estimation and removal of trend and seasonality (of known period) from an
observed time series. These are illustrated with reference to the data sets in Section
1.1. The calculations in all the examples can be carried out using the time series pack-
age ITSM, the student version of which is supplied on the enclosed CD. The data sets
are contained in files with names ending in .TSM. For example, the Australian red
wine sales are filed as WINE.TSM. Most of the topics covered in this chapter will
be developed more fully in later sections of the book. The reader who is not already
familiar with random variables and random vectors should first read Appendix A,
where a concise account of the required background is given.

1.1 Examples of Time Series

A time series is a set of observations xt , each one being recorded at a specific time t .
A discrete-time time series (the type to which this book is primarily devoted) is one
in which the set T0 of times at which observations are made is a discrete set, as is the
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Figure 1-1
The Australian red wine
sales, Jan. ‘80 – Oct. ‘91.  
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case, for example, when observations are made at fixed time intervals. Continuous-
time time series are obtained when observations are recorded continuously over some
time interval, e.g., when T0 � [0, 1].

Example 1.1.1 Australian red wine sales; WINE.TSM

Figure 1.1 shows the monthly sales (in kiloliters) of red wine by Australian winemak-
ers from January 1980 through October 1991. In this case the set T0 consists of the
142 times {(Jan. 1980), (Feb. 1980), . . . ,(Oct. 1991)}. Given a set of n observations
made at uniformly spaced time intervals, it is often convenient to rescale the time
axis in such a way that T0 becomes the set of integers {1, 2, . . . , n}. In the present
example this amounts to measuring time in months with (Jan. 1980) as month 1. Then
T0 is the set {1, 2, . . . , 142}. It appears from the graph that the sales have an upward
trend and a seasonal pattern with a peak in July and a trough in January. To plot the
data using ITSM, run the program by double-clicking on the ITSM icon and then
select the option File>Project>Open>Univariate, click OK, and select the file
WINE.TSM. The graph of the data will then appear on your screen.

Example 1.1.2 All-star baseball games, 1933–1995

Figure 1.2 shows the results of the all-star games by plotting xt , where

xt �
{

1 if the National League won in year t,

−1 if the American League won in year t .
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Figure 1-2
Results of the

all-star baseball
games, 1933–1995.
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This is a series with only two possible values, ±1. It also has some missing values,
since no game was played in 1945, and two games were scheduled for each of the
years 1959–1962.

Example 1.1.3 Accidental deaths, U.S.A., 1973–1978; DEATHS.TSM

Like the red wine sales, the monthly accidental death figures show a strong seasonal
pattern, with the maximum for each year occurring in July and the minimum for each
year occurring in February. The presence of a trend in Figure 1.3 is much less apparent
than in the wine sales. In Section 1.5 we shall consider the problem of representing
the data as the sum of a trend, a seasonal component, and a residual term.

Example 1.1.4 A signal detection problem; SIGNAL.TSM

Figure 1.4 shows simulated values of the series

Xt � cos
(

t

10

)
+Nt, t � 1, 2, . . . , 200,

where {Nt} is a sequence of independent normal random variables, with mean 0
and variance 0.25. Such a series is often referred to as signal plus noise, the signal
being the smooth function, St � cos( t

10 ) in this case. Given only the data Xt , how
can we determine the unknown signal component? There are many approaches to
this general problem under varying assumptions about the signal and the noise. One
simple approach is to smooth the data by expressing Xt as a sum of sine waves of
various frequencies (see Section 4.2) and eliminating the high-frequency components.
If we do this to the values of {Xt} shown in Figure 1.4 and retain only the lowest



The Bartlett Press, Inc. brockwel 2 · v · 2002 9:02 a.m. Page 4

4 Chapter 1 Introduction

Figure 1-3
The monthly accidental
deaths data, 1973–1978.  
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Figure 1-4
The series {Xt } of
Example 1.1.4.
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Figure 1-5
Population of the
U.S.A. at ten-year

intervals, 1790–1990.  
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Figure 1-6
Strikes in the

U.S.A., 1951–1980.  
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3.5% of the frequency components, we obtain the estimate of the signal also shown
in Figure 1.4. The waveform of the signal is quite close to that of the true signal in
this case, although its amplitude is somewhat smaller.

Example 1.1.5 Population of the U.S.A., 1790–1990; USPOP.TSM

The population of the U.S.A., measured at ten-year intervals, is shown in Figure 1.5.
The graph suggests the possibility of fitting a quadratic or exponential trend to the
data. We shall explore this further in Section 1.3.

Example 1.1.6 Number of strikes per year in the U.S.A., 1951–1980; STRIKES.TSM

The annual numbers of strikes in the U.S.A. for the years 1951–1980 are shown in
Figure 1.6. They appear to fluctuate erratically about a slowly changing level.

1.2 Objectives of Time Series Analysis

The examples considered in Section 1.1 are an extremely small sample from the
multitude of time series encountered in the fields of engineering, science, sociology,
and economics. Our purpose in this book is to study techniques for drawing inferences
from such series. Before we can do this, however, it is necessary to set up a hypothetical
probability model to represent the data. After an appropriate family of models has
been chosen, it is then possible to estimate parameters, check for goodness of fit to
the data, and possibly to use the fitted model to enhance our understanding of the
mechanism generating the series. Once a satisfactory model has been developed, it
may be used in a variety of ways depending on the particular field of application.

The model may be used simply to provide a compact description of the data. We
may, for example, be able to represent the accidental deaths data of Example 1.1.3 as
the sum of a specified trend, and seasonal and random terms. For the interpretation
of economic statistics such as unemployment figures, it is important to recognize the
presence of seasonal components and to remove them so as not to confuse them with
long-term trends. This process is known as seasonal adjustment. Other applications
of time series models include separation (or filtering) of noise from signals as in
Example 1.1.4, prediction of future values of a series such as the red wine sales in
Example 1.1.1 or the population data in Example 1.1.5, testing hypotheses such as
global warming using recorded temperature data, predicting one series from obser-
vations of another, e.g., predicting future sales using advertising expenditure data,
and controlling future values of a series by adjusting parameters. Time series models
are also useful in simulation studies. For example, the performance of a reservoir
depends heavily on the random daily inputs of water to the system. If these are mod-
eled as a time series, then we can use the fitted model to simulate a large number
of independent sequences of daily inputs. Knowing the size and mode of operation
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of the reservoir, we can determine the fraction of the simulated input sequences that
cause the reservoir to run out of water in a given time period. This fraction will then
be an estimate of the probability of emptiness of the reservoir at some time in the
given period.

1.3 Some Simple Time Series Models

An important part of the analysis of a time series is the selection of a suitable proba-
bility model (or class of models) for the data. To allow for the possibly unpredictable
nature of future observations it is natural to suppose that each observation xt is a
realized value of a certain random variable Xt .

Definition 1.3.1 A time series model for the observed data {xt} is a specification of the joint
distributions (or possibly only the means and covariances) of a sequence of random
variables {Xt} of which {xt} is postulated to be a realization.

Remark. We shall frequently use the term time series to mean both the data and
the process of which it is a realization.

A complete probabilistic time series model for the sequence of random vari-
ables {X1, X2, . . .} would specify all of the joint distributions of the random vectors
(X1, . . . , Xn)

′, n � 1, 2, . . ., or equivalently all of the probabilities

P [X1 ≤ x1, . . . , Xn ≤ xn], −∞ < x1, . . . , xn < ∞, n � 1, 2, . . . .

Such a specification is rarely used in time series analysis (unless the data are generated
by some well-understood simple mechanism), since in general it will contain far too
many parameters to be estimated from the available data. Instead we specify only the
first- and second-order moments of the joint distributions, i.e., the expected values
EXt and the expected products E(Xt+hXt), t � 1, 2, . . ., h � 0, 1, 2, . . ., focusing
on properties of the sequence {Xt} that depend only on these. Such properties of {Xt}
are referred to as second-order properties. In the particular case where all the joint
distributions are multivariate normal, the second-order properties of {Xt} completely
determine the joint distributions and hence give a complete probabilistic characteri-
zation of the sequence. In general we shall lose a certain amount of information by
looking at time series “through second-order spectacles”; however, as we shall see
in Chapter 2, the theory of minimum mean squared error linear prediction depends
only on the second-order properties, thus providing further justification for the use
of the second-order characterization of time series models.

Figure 1.7 shows one of many possible realizations of {St , t � 1, . . . , 200}, where
{St} is a sequence of random variables specified in Example 1.3.3 below. In most
practical problems involving time series we see only one realization. For example,
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there is only one available realization of Fort Collins’s annual rainfall for the years
1900–1996, but we imagine it to be one of the many sequences that might have
occurred. In the following examples we introduce some simple time series models.
One of our goals will be to expand this repertoire so as to have at our disposal a broad
range of models with which to try to match the observed behavior of given data sets.

1.3.1 Some Zero-Mean Models

Example 1.3.1 iid noise

Perhaps the simplest model for a time series is one in which there is no trend or
seasonal component and in which the observations are simply independent and iden-
tically distributed (iid) random variables with zero mean. We refer to such a sequence
of random variables X1, X2, . . . as iid noise. By definition we can write, for any
positive integer n and real numbers x1, . . . , xn,

P [X1 ≤ x1, . . . , Xn ≤ xn] � P [X1 ≤ x1] · · ·P [Xn ≤ xn] � F(x1) · · ·F(xn),
where F(·) is the cumulative distribution function (see Section A.1) of each of
the identically distributed random variables X1, X2, . . . . In this model there is no
dependence between observations. In particular, for all h ≥ 1 and all x, x1, . . . , xn,

P [Xn+h ≤ x|X1 � x1, . . . , Xn � xn] � P [Xn+h ≤ x],

showing that knowledge of X1, . . . , Xn is of no value for predicting the behavior
of Xn+h. Given the values of X1, . . . , Xn, the function f that minimizes the mean
squared error E

[
(Xn+h − f (X1, . . . , Xn))

2
]

is in fact identically zero (see Problem
1.2). Although this means that iid noise is a rather uninteresting process for forecast-
ers, it plays an important role as a building block for more complicated time series
models.

Example 1.3.2 A binary process

As an example of iid noise, consider the sequence of iid random variables {Xt, t �
1, 2, . . . , } with

P [Xt � 1] � p, P [Xt � −1] � 1 − p,

where p � 1
2 . The time series obtained by tossing a penny repeatedly and scoring

+1 for each head and −1 for each tail is usually modeled as a realization of this
process. A priori we might well consider the same process as a model for the all-star
baseball games in Example 1.1.2. However, even a cursory inspection of the results
from 1963–1982, which show the National League winning 19 of 20 games, casts
serious doubt on the hypothesis P [Xt � 1] � 1

2 .
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Example 1.3.3 Random walk

The random walk {St , t � 0, 1, 2, . . .} (starting at zero) is obtained by cumulatively
summing (or “integrating”) iid random variables. Thus a random walk with zero mean
is obtained by defining S0 � 0 and

St � X1 +X2 + · · · +Xt, for t � 1, 2, . . . ,

where {Xt} is iid noise. If {Xt} is the binary process of Example 1.3.2, then {St , t �
0, 1, 2, . . . , } is called a simple symmetric random walk. This walk can be viewed
as the location of a pedestrian who starts at position zero at time zero and at each
integer time tosses a fair coin, stepping one unit to the right each time a head appears
and one unit to the left for each tail. A realization of length 200 of a simple symmetric
random walk is shown in Figure 1.7. Notice that the outcomes of the coin tosses can
be recovered from {St , t � 0, 1, . . .} by differencing. Thus the result of the t th toss
can be found from St − St−1 � Xt .

1.3.2 Models with Trend and Seasonality

In several of the time series examples of Section 1.1 there is a clear trend in the data.
An increasing trend is apparent in both the Australian red wine sales (Figure 1.1)
and the population of the U.S.A. (Figure 1.5). In both cases a zero-mean model for
the data is clearly inappropriate. The graph of the population data, which contains no
apparent periodic component, suggests trying a model of the form

Xt � mt + Yt ,

Figure 1-7
One realization of a
simple random walk

{St , t � 0,1,2, . . . ,200}
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where mt is a slowly changing function known as the trend component and Yt has
zero mean. A useful technique for estimating mt is the method of least squares (some
other methods are considered in Section 1.5).

In the least squares procedure we attempt to fit a parametric family of functions,
e.g.,

mt � a0 + a1t + a2t
2, (1.3.1)

to the data {x1, . . . , xn} by choosing the parameters, in this illustration a0, a1, and a2, to
minimize

∑n

t�1(xt−mt)
2. This method of curve fitting is called least squares regres-

sion and can be carried out using the program ITSM and selecting the Regression
option.

Example 1.3.4 Population of the U.S.A., 1790–1990

To fit a function of the form (1.3.1) to the population data shown in Figure 1.5 we
relabel the time axis so that t � 1 corresponds to 1790 and t � 21 corresponds to
1990. Run ITSM, select File>Project>Open>Univariate, and open the file US-
POP.TSM. Then select Regression>Specify, choose Polynomial Regression
with order equal to 2, and click OK. Then select Regression>Estimation>Least
Squares, and you will obtain the following estimated parameter values in the model
(1.3.1):

â0 � 6.9579 × 106,

â1 � −2.1599 × 106,

and

â2 � 6.5063 × 105.

A graph of the fitted function is shown with the original data in Figure 1.8. The
estimated values of the noise process Yt , 1 ≤ t ≤ 21, are the residuals obtained by
subtraction of m̂t � â0 + â1t + â2t

2 from xt .
The estimated trend component m̂t furnishes us with a natural predictor of future

values of Xt . For example, if we estimate the noise Y22 by its mean value, i.e., zero,
then (1.3.1) gives the estimated U.S. population for the year 2000 as

m̂22 � 6.9579 × 106 − 2.1599 × 106 × 22 + 6.5063 × 105 × 222 � 274.35 × 106.

However, if the residuals {Yt} are highly correlated, we may be able to use their values
to give a better estimate of Y22 and hence of the population X22 in the year 2000.

Example 1.3.5 Level of Lake Huron 1875–1972; LAKE.DAT

A graph of the level in feet of Lake Huron (reduced by 570) in the years 1875–1972
is displayed in Figure 1.9. Since the lake level appears to decline at a roughly linear
rate, ITSM was used to fit a model of the form

Xt � a0 + a1t + Yt , t � 1, . . . , 98 (1.3.2)
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Figure 1-8
Population of the U.S.A.

showing the quadratic trend
fitted by least squares.  
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(with the time axis relabeled as in Example 1.3.4). The least squares estimates of the
parameter values are

â0 � 10.202 and â1 � −.0242.

(The resulting least squares line, â0 + â1t , is also displayed in Figure 1.9.) The
estimates of the noise,Yt , in the model (1.3.2) are the residuals obtained by subtracting
the least squares line from xt and are plotted in Figure 1.10. There are two interesting

Figure 1-9
Level of Lake Huron

1875–1972 showing the
line fitted by least squares.
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Figure 1-10
Residuals from fitting a
line to the Lake Huron

data in Figure 1.9.
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features of the graph of the residuals. The first is the absence of any discernible trend.
The second is the smoothness of the graph. (In particular, there are long stretches of
residuals that have the same sign. This would be very unlikely to occur if the residuals
were observations of iid noise with zero mean.) Smoothness of the graph of a time
series is generally indicative of the existence of some form of dependence among the
observations.

Such dependence can be used to advantage in forecasting future values of the
series. If we were to assume the validity of the fitted model with iid residuals {Yt}, then
the minimum mean squared error predictor of the next residual (Y99) would be zero
(by Problem 1.2). However, Figure 1.10 strongly suggests that Y99 will be positive.

How then do we quantify dependence, and how do we construct models for fore-
casting that incorporate dependence of a particular type? To deal with these questions,
Section 1.4 introduces the autocorrelation function as a measure of dependence, and
stationary processes as a family of useful models exhibiting a wide variety of depen-
dence structures.

Harmonic Regression
Many time series are influenced by seasonally varying factors such as the weather, the
effect of which can be modeled by a periodic component with fixed known period. For
example, the accidental deaths series (Figure 1.3) shows a repeating annual pattern
with peaks in July and troughs in February, strongly suggesting a seasonal factor
with period 12. In order to represent such a seasonal effect, allowing for noise but
assuming no trend, we can use the simple model,

Xt � st + Yt ,
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where st is a periodic function of t with period d (st−d � st ). A convenient choice for
st is a sum of harmonics (or sine waves) given by

st � a0 +
k∑

j�1

(aj cos(λj t)+ bj sin(λj t)), (1.3.3)

where a0, a1, . . . , ak and b1, . . . , bk are unknown parameters and λ1, . . . , λk are fixed
frequencies, each being some integer multiple of 2π/d. To carry out harmonic re-
gression using ITSM, select Regression>Specify and check Include intercept
term and Harmonic Regression. Then specify the number of harmonics (k in
(1.3.3)) and enter k integer-valued Fourier indices f1, . . . , fk. For a sine wave with
period d, set f1 � n/d, where n is the number of observations in the time series. (If
n/d is not an integer, you will need to delete a few observations from the beginning
of the series to make it so.) The other k− 1 Fourier indices should be positive integer
multiples of the first, corresponding to harmonics of the fundamental sine wave with
period d. Thus to fit a single sine wave with period 365 to 365 daily observations we
would choose k � 1 and f1 � 1. To fit a linear combination of sine waves with periods
365/j , j � 1, . . . , 4, we would choose k � 4 and fj � j , j � 1, . . . , 4. Once k and
f1, . . . , fk have been specified, click OK and then select Regression>Estimation
>Least Squares to obtain the required regression coefficients. To see how well the
fitted function matches the data, select Regression>Show fit.

Example 1.3.6 Accidental deaths

To fit a sum of two harmonics with periods twelve months and six months to the
monthly accidental deaths data x1, . . . , xn with n � 72, we choose k � 2, f1 �

Figure 1-11
The estimated harmonic

component of the
accidental deaths
data from ITSM.  
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n/12 � 6, and f2 � n/6 � 12. Using ITSM as described above, we obtain the fitted
function shown in Figure 1.11. As can be seen from the figure, the periodic character
of the series is captured reasonably well by this fitted function. In practice, it is worth
experimenting with several different combinations of harmonics in order to find a sat-
isfactory estimate of the seasonal component. The program ITSM also allows fitting
a linear combination of harmonics and polynomial trend by checking both Harmonic
Regression and Polynomial Regression in the Regression>Specification
dialog box. Other methods for dealing with seasonal variation in the presence of
trend are described in Section 1.5.

1.3.3 A General Approach to Time Series Modeling

The examples of the previous section illustrate a general approach to time series
analysis that will form the basis for much of what is done in this book. Before
introducing the ideas of dependence and stationarity, we outline this approach to
provide the reader with an overview of the way in which the various ideas of this
chapter fit together.

• Plot the series and examine the main features of the graph, checking in particular
whether there is
(a) a trend,
(b) a seasonal component,
(c) any apparent sharp changes in behavior,
(d) any outlying observations.

• Remove the trend and seasonal components to get stationary residuals (as defined
in Section 1.4). To achieve this goal it may sometimes be necessary to apply a
preliminary transformation to the data. For example, if the magnitude of the
fluctuations appears to grow roughly linearly with the level of the series, then
the transformed series {lnX1, . . . , lnXn} will have fluctuations of more constant
magnitude. See, for example, Figures 1.1 and 1.17. (If some of the data are
negative, add a positive constant to each of the data values to ensure that all
values are positive before taking logarithms.) There are several ways in which
trend and seasonality can be removed (see Section 1.5), some involving estimating
the components and subtracting them from the data, and others depending on
differencing the data, i.e., replacing the original series {Xt} by {Yt :� Xt −Xt−d}
for some positive integer d. Whichever method is used, the aim is to produce a
stationary series, whose values we shall refer to as residuals.

• Choose a model to fit the residuals, making use of various sample statistics in-
cluding the sample autocorrelation function to be defined in Section 1.4.

• Forecasting will be achieved by forecasting the residuals and then inverting the
transformations described above to arrive at forecasts of the original series {Xt}.
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• An extremely useful alternative approach touched on only briefly in this book is
to express the series in terms of its Fourier components, which are sinusoidal
waves of different frequencies (cf. Example 1.1.4). This approach is especially
important in engineering applications such as signal processing and structural
design. It is important, for example, to ensure that the resonant frequency of a
structure does not coincide with a frequency at which the loading forces on the
structure have a particularly large component.

1.4 Stationary Models and the Autocorrelation Function

Loosely speaking, a time series {Xt, t � 0,±1, . . .} is said to be stationary if it has sta-
tistical properties similar to those of the “time-shifted” series {Xt+h, t � 0,±1, . . .},
for each integer h. Restricting attention to those properties that depend only on the
first- and second-order moments of {Xt}, we can make this idea precise with the
following definitions.

Definition 1.4.1 Let {Xt} be a time series with E(X2
t ) < ∞. The mean function of {Xt} is

µX(t) � E(Xt).

The covariance function of {Xt} is

γX(r, s) � Cov(Xr,Xs) � E[(Xr − µX(r))(Xs − µX(s))]

for all integers r and s.

Definition 1.4.2 {Xt} is (weakly) stationary if

(i) µX(t) is independent of t,

and

(ii) γX(t + h, t) is independent of t for each h.

Remark 1. Strict stationarity of a time series {Xt, t � 0,±1, . . .} is defined by the
condition that (X1, . . . , Xn) and (X1+h, . . . , Xn+h) have the same joint distributions
for all integers h and n > 0. It is easy to check that if {Xt} is strictly stationary and
EX2

t < ∞ for all t , then {Xt} is also weakly stationary (Problem 1.3). Whenever we
use the term stationary we shall mean weakly stationary as in Definition 1.4.2, unless
we specifically indicate otherwise.

Remark 2. In view of condition (ii), whenever we use the term covariance function
with reference to a stationary time series {Xt} we shall mean the function γX of one
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variable, defined by

γX(h) :� γX(h, 0) � γX(t + h, t).

The function γX(·) will be referred to as the autocovariance function and γX(h) as its
value at lag h.

Definition 1.4.3 Let {Xt} be a stationary time series. The autocovariance function (ACVF) of
{Xt} at lag h is

γX(h) � Cov(Xt+h, Xt).

The autocorrelation function (ACF) of {Xt} at lag h is

ρX(h) ≡ γX(h)

γX(0)
� Cor(Xt+h, Xt).

In the following examples we shall frequently use the easily verified linearity prop-
erty of covariances, that if EX2 < ∞, EY 2 < ∞, EZ2 < ∞ and a, b, and c are any
real constants, then

Cov(aX + bY + c, Z) � a Cov(X,Z)+ bCov(Y, Z).

Example 1.4.1 iid noise

If {Xt} is iid noise and E(X2
t ) � σ 2 < ∞, then the first requirement of Definition

1.4.2 is obviously satisfied, since E(Xt) � 0 for all t . By the assumed independence,

γX(t + h, t) �
{
σ 2, if h � 0,

0, if h �� 0,

which does not depend on t . Hence iid noise with finite second moment is stationary.
We shall use the notation

{Xt} ∼ IID
(
0, σ 2

)
to indicate that the random variables Xt are independent and identically distributed
random variables, each with mean 0 and variance σ 2.

Example 1.4.2 White noise

If {Xt} is a sequence of uncorrelated random variables, each with zero mean and
variance σ 2, then clearly {Xt} is stationary with the same covariance function as the
iid noise in Example 1.4.1. Such a sequence is referred to as white noise (with mean
0 and variance σ 2). This is indicated by the notation

{Xt} ∼ WN
(
0, σ 2

)
.
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Clearly, every IID
(
0, σ 2

)
sequence is WN

(
0, σ 2

)
but not conversely (see Problem 1.8

and the ARCH(1) process of Section 10.3).

Example 1.4.3 The random walk

If {St} is the random walk defined in Example 1.3.3 with {Xt} as in Example 1.4.1,
then ESt � 0, E(S2

t ) � tσ 2 < ∞ for all t , and, for h ≥ 0,

γS(t + h, t) � Cov(St+h, St )

� Cov(St +Xt+1 + · · · +Xt+h, St )

� Cov(St , St )

� tσ 2.

Since γS(t + h, t) depends on t , the series {St} is not stationary.

Example 1.4.4 First-order moving average or MA(1) process

Consider the series defined by the equation

Xt � Zt + θZt−1, t � 0,±1, . . . , (1.4.1)

where {Zt} ∼ WN
(
0, σ 2

)
and θ is a real-valued constant. From (1.4.1) we see that

EXt � 0, EX2
t � σ 2(1 + θ 2) < ∞, and

γX(t + h, t) �


σ 2

(
1 + θ 2

)
, if h � 0,

σ 2θ, if h � ±1,

0, if |h| > 1.

Thus the requirements of Definition 1.4.2 are satisfied, and {Xt} is stationary. The
autocorrelation function of {Xt} is

ρX(h) �


1, if h � 0,

θ/
(
1 + θ 2

)
, if h � ±1,

0, if |h| > 1.

Example 1.4.5 First-order autoregression or AR(1) process

Let us assume now that {Xt} is a stationary series satisfying the equations

Xt � φXt−1 + Zt, t � 0,±1, . . . , (1.4.2)

where {Zt} ∼ WN(0, σ 2), |φ| < 1, andZt is uncorrelated withXs for each s < t . (We
shall show in Section 2.2 that there is in fact exactly one such solution of (1.4.2).) By
taking expectations on each side of (1.4.2) and using the fact that EZt � 0, we see
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at once that

EXt � 0.

To find the autocorrelation function of {Xt} we multiply each side of (1.4.2) by Xt−h
(h > 0) and then take expectations to get

γX(h) � Cov(Xt ,Xt−h)

� Cov(φXt−1, Xt−h)+ Cov(Zt , Xt−h)

� φγX(h− 1)+ 0 � · · · � φhγ
X
(0).

Observing that γ (h) � γ (−h) and using Definition 1.4.3, we find that

ρX(h) � γX(h)

γX(0)
� φ|h|, h � 0,±1, . . . .

It follows from the linearity of the covariance function in each of its arguments and
the fact that Zt is uncorrelated with Xt−1 that

γX(0) � Cov(Xt ,Xt) � Cov(φXt−1 + Zt, φXt−1 + Zt) � φ2γX(0)+ σ 2

and hence that γX(0) � σ 2/
(
1 − φ2

)
.

1.4.1 The Sample Autocorrelation Function

Although we have just seen how to compute the autocorrelation function for a few
simple time series models, in practical problems we do not start with a model, but
with observed data {x1, x2, . . . , xn}. To assess the degree of dependence in the data
and to select a model for the data that reflects this, one of the important tools we
use is the sample autocorrelation function (sample ACF) of the data. If we believe
that the data are realized values of a stationary time series {Xt}, then the sample
ACF will provide us with an estimate of the ACF of {Xt}. This estimate may suggest
which of the many possible stationary time series models is a suitable candidate for
representing the dependence in the data. For example, a sample ACF that is close
to zero for all nonzero lags suggests that an appropriate model for the data might
be iid noise. The following definitions are natural sample analogues of those for the
autocovariance and autocorrelation functions given earlier for stationary time series
models.
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Definition 1.4.4 Let x1, . . . , xn be observations of a time series. The sample mean of x1, . . . , xn is

x̄ � 1
n

n∑
t�1

xt .

The sample autocovariance function is

γ̂ (h) :� n−1
n−|h|∑
t�1

(xt+|h| − x̄)(xt − x̄), −n < h < n.

The sample autocorrelation function is

ρ̂(h) � γ̂ (h)

γ̂ (0)
, −n < h < n.

Remark 3. For h ≥ 0, γ̂ (h) is approximately equal to the sample covariance of
the n − h pairs of observations (x1, x1+h), (x2, x2+h), . . . , (xn−h, xn). The difference
arises from use of the divisor n instead of n − h and the subtraction of the overall
mean, x̄, from each factor of the summands. Use of the divisor n ensures that the
sample covariance matrix 
̂n :� [γ̂ (i − j)]ni,j�1 is nonnegative definite (see Section
2.4.2).

Remark 4. Like the sample covariance matrix defined in Remark 3, the sample
correlation matrix R̂n :� [ρ̂(i − j)]ni,j�1 is nonnegative definite. Each of its diagonal
elements is equal to 1, since ρ̂(0) � 1.

Figure 1-12
200 simulated values
of iid N(0,1) noise.
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Example 1.4.6 Figure 1.12 shows 200 simulated values of normally distributed iid (0, 1), denoted
by IID N(0, 1), noise. Figure 1.13 shows the corresponding sample autocorrelation
function at lags 0, 1, . . . , 40. Since ρ(h) � 0 for h > 0, one would also expect the
corresponding sample autocorrelations to be near 0. It can be shown, in fact, that for iid
noise with finite variance, the sample autocorrelations ρ̂(h), h > 0, are approximately
IID N(0, 1/n) for n large (see TSTM p. 222). Hence, approximately 95% of the
sample autocorrelations should fall between the bounds ±1.96/

√
n (since 1.96 is

the .975 quantile of the standard normal distribution). Therefore, in Figure 1.13 we
would expect roughly 40(.05) � 2 values to fall outside the bounds. To simulate 200
values of IID N(0, 1) noise using ITSM, select File>Project>New>Univariate
then Model>Simulate. In the resulting dialog box, enter 200 for the required Number
of Observations. (The remaining entries in the dialog box can be left as they are,
since the model assumed by ITSM, until you enter another, is IID N(0, 1) noise. If
you wish to reproduce exactly the same sequence at a later date, record the Random
Number Seed for later use. By specifying different values for the random number
seed you can generate independent realizations of your time series.) Click on OK and
you will see the graph of your simulated series. To see its sample autocorrelation
function together with the autocorrelation function of the model that generated it,
click on the third yellow button at the top of the screen and you will see the two
graphs superimposed (with the latter in red.) The horizontal lines on the graph are
the bounds ±1.96/

√
n.

Remark 5. The sample autocovariance and autocorrelation functions can be com-
puted for any data set {x1, . . . , xn} and are not restricted to observations from a

Figure 1-13
The sample autocorrelation
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Figure 1.12 showing

the bounds ±1.96/√n. Lag 
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Figure 1-14
The sample autocorrelation
function for the Australian

red wine sales showing
the bounds ±1.96/√n. Lag 
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stationary time series. For data containing a trend, |ρ̂(h)| will exhibit slow decay as
h increases, and for data with a substantial deterministic periodic component, |ρ̂(h)|
will exhibit similar behavior with the same periodicity. (See the sample ACF of the
Australian red wine sales in Figure 1.14 and Problem 1.9.) Thus ρ̂(·) can be useful
as an indicator of nonstationarity (see also Section 6.1).

1.4.2 A Model for the Lake Huron Data

As noted earlier, an iid noise model for the residuals {y1, . . . , y98} obtained by fitting
a straight line to the Lake Huron data in Example 1.3.5 appears to be inappropriate.
This conclusion is confirmed by the sample ACF of the residuals (Figure 1.15), which
has three of the first forty values well outside the bounds ±1.96/

√
98.

The roughly geometric decay of the first few sample autocorrelations (with
ρ̂(h + 1)/ρ̂(h) ≈ 0.7) suggests that an AR(1) series (with φ ≈ 0.7) might pro-
vide a reasonable model for these residuals. (The form of the ACF for an AR(1)
process was computed in Example 1.4.5.)

To explore the appropriateness of such a model, consider the points (y1, y2),
(y2, y3), . . . , (y97, y98) plotted in Figure 1.16. The graph does indeed suggest a linear
relationship between yt and yt−1. Using simple least squares estimation to fit a straight
line of the form yt � ayt−1, we obtain the model

Yt � .791Yt−1 + Zt, (1.4.3)

where {Zt} is iid noise with variance
∑98

t�2(yt − .791yt−1)
2/97 � .5024. The sample

ACF of the estimated noise sequence zt � yt − .791yt−1, t � 2, . . . , 98, is slightly
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Figure 1-15
The sample autocorrelation

function for the Lake
Huron residuals of

Figure 1.10 showing
the bounds ±1.96/√n. Lag 
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outside the bounds ±1.96/
√

97 at lag 1 (ρ̂(1) � .216), but it is inside the bounds for
all other lags up to 40. This check that the estimated noise sequence is consistent with
the iid assumption of (1.4.3) reinforces our belief in the fitted model. More goodness
of fit tests for iid noise sequences are described in Section 1.6. The estimated noise
sequence {zt} in this example passes them all, providing further support for the model
(1.4.3).

Figure 1-16
Scatter plot of

(yt−1, yt ), t � 2, . . . ,98,
for the data in Figure 1.10
showing the least squares
regression line y � .791x .
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A better fit to the residuals in equation (1.3.2) is provided by the second-order
autoregression

Yt � φ1Yt−1 + φ2Yt−2 + Zt, (1.4.4)

where {Zt} is iid noise with variance σ 2. This is analogous to a linear model in
which Yt is regressed on the previous two values Yt−1 and Yt−2 of the time series. The
least squares estimates of the parameters φ1 and φ2, found by minimizing

∑98
t�3(yt −

φ1yt−1 − φ2yt−2)
2, are φ̂1 � 1.002 and φ̂2 � −.2834. The estimate of σ 2 is σ̂ 2 �∑98

t�3(yt − φ̂1yt−1 − φ̂2yt−2)
2/96 � .4460, which is approximately 11% smaller than

the estimate of the noise variance for the AR(1) model (1.4.3). The improved fit is
indicated by the sample ACF of the estimated residuals, yt − φ̂1yt−1 − φ̂2yt−2, which
falls well within the bounds ±1.96/

√
96 for all lags up to 40.

1.5 Estimation and Elimination of Trend and Seasonal Components

The first step in the analysis of any time series is to plot the data. If there are any
apparent discontinuities in the series, such as a sudden change of level, it may be
advisable to analyze the series by first breaking it into homogeneous segments. If
there are outlying observations, they should be studied carefully to check whether
there is any justification for discarding them (as for example if an observation has
been incorrectly recorded). Inspection of a graph may also suggest the possibility
of representing the data as a realization of the process (the classical decomposition
model)

Xt � mt + st + Yt , (1.5.1)

wheremt is a slowly changing function known as a trend component, st is a function
with known period d referred to as a seasonal component, and Yt is a random noise
component that is stationary in the sense of Definition 1.4.2. If the seasonal and noise
fluctuations appear to increase with the level of the process, then a preliminary trans-
formation of the data is often used to make the transformed data more compatible
with the model (1.5.1). Compare, for example, the red wine sales in Figure 1.1 with
the transformed data, Figure 1.17, obtained by applying a logarithmic transformation.
The transformed data do not exhibit the increasing fluctuation with increasing level
that was apparent in the original data. This suggests that the model (1.5.1) is more
appropriate for the transformed than for the original series. In this section we shall
assume that the model (1.5.1) is appropriate (possibly after a preliminary transfor-
mation of the data) and examine some techniques for estimating the components mt ,
st , and Yt in the model.

Our aim is to estimate and extract the deterministic components mt and st in
the hope that the residual or noise component Yt will turn out to be a stationary time
series. We can then use the theory of such processes to find a satisfactory probabilistic
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Figure 1-17
The natural logarithms
of the red wine data.
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model for the process Yt , to analyze its properties, and to use it in conjunction with
mt and st for purposes of prediction and simulation of {Xt}.

Another approach, developed extensively by Box and Jenkins (1976), is to apply
differencing operators repeatedly to the series {Xt} until the differenced observations
resemble a realization of some stationary time series {Wt}. We can then use the theory
of stationary processes for the modeling, analysis, and prediction of {Wt} and hence
of the original process. The various stages of this procedure will be discussed in detail
in Chapters 5 and 6.

The two approaches to trend and seasonality removal, (1) by estimation of mt

and st in (1.5.1) and (2) by differencing the series {Xt}, will now be illustrated with
reference to the data introduced in Section 1.1.

1.5.1 Estimation and Elimination of Trend in the Absence of Seasonality

In the absence of a seasonal component the model (1.5.1) becomes the following.

Nonseasonal Model with Trend:

Xt � mt + Yt , t � 1, . . . , n, (1.5.2)

where EYt � 0.

(If EYt �� 0, then we can replace mt and Yt in (1.5.2) with mt + EYt and Yt − EYt ,
respectively.)
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Method 1: Trend Estimation
Moving average and spectral smoothing are essentially nonparametric methods for
trend (or signal) estimation and not for model building. Special smoothing filters can
also be designed to remove periodic components as described under Method S1 below.
The choice of smoothing filter requires a certain amount of subjective judgment, and
it is recommended that a variety of filters be tried in order to get a good idea of the
underlying trend. Exponential smoothing, since it is based on a moving average of
past values only, is often used for forecasting, the smoothed value at the present time
being used as the forecast of the next value.

To construct a model for the data (with no seasonality) there are two general
approaches, both available in ITSM. One is to fit a polynomial trend (by least squares)
as described in Method 1(d) below, then to subtract the fitted trend from the data and
to find an appropriate stationary time series model for the residuals. The other is
to eliminate the trend by differencing as described in Method 2 and then to find an
appropriate stationary model for the differenced series. The latter method has the
advantage that it usually requires the estimation of fewer parameters and does not
rest on the assumption of a trend that remains fixed throughout the observation period.
The study of the residuals (or of the differenced series) is taken up in Section 1.6.

(a) Smoothing with a finite moving average filter. Let q be a nonnegative
integer and consider the two-sided moving average

Wt � (2q + 1)−1
q∑

j�−q
Xt−j (1.5.3)

of the process {Xt} defined by (1.5.2). Then for q + 1 ≤ t ≤ n− q,

Wt � (2q + 1)−1
q∑

j�−q
mt−j + (2q + 1)−1

q∑
j�−q

Yt−j ≈ mt, (1.5.4)

assuming that mt is approximately linear over the interval [t − q, t + q] and that the
average of the error terms over this interval is close to zero (see Problem 1.11).

The moving average thus provides us with the estimates

m̂t � (2q + 1)−1
q∑

j�−q
Xt−j , q + 1 ≤ t ≤ n− q. (1.5.5)

Since Xt is not observed for t ≤ 0 or t > n, we cannot use (1.5.5) for t ≤ q or
t > n − q. The program ITSM deals with this problem by defining Xt :� X1 for
t < 1 and Xt :� Xn for t > n.

Example 1.5.1 The result of applying the moving-average filter (1.5.5) with q � 2 to the strike data of
Figure 1.6 is shown in Figure 1.18. The estimated noise terms Ŷt � Xt−m̂t are shown
in Figure 1.19. As expected, they show no apparent trend. To apply this filter using
ITSM, open the project STRIKES.TSM, select Smooth>Moving Average, specify
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Figure 1-18
Simple 5-term moving
average m̂t of the strike
data from Figure 1.6.  
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2 for the filter order, and enter the weights 1,1,1 for Theta(0), Theta(1), and Theta(2)
(these are automatically normalized so that the sum of the weights is one). Then click
OK.

It is useful to think of {m̂t} in (1.5.5) as a process obtained from {Xt}by application
of a linear operator or linear filter m̂t �

∑∞
j�−∞ ajXt−j with weights aj � (2q +

1)−1,−q ≤ j ≤ q. This particular filter is a low-pass filter in the sense that it takes the

Figure 1-19
Residuals Ŷt � Xt − m̂t

after subtracting the
5-term moving average

from the strike data
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Figure 1-20
Smoothing with a

low-pass linear filter.

data {Xt} and removes from it the rapidly fluctuating (or high frequency) component
{Ŷt} to leave the slowly varying estimated trend term {m̂t} (see Figure 1.20).

The particular filter (1.5.5) is only one of many that could be used for smoothing.
For large q, provided that (2q + 1)−1

∑q

j�−q Yt−j ≈ 0, it not only will attenuate
noise but at the same time will allow linear trend functions mt � c0 + c1t to pass
without distortion (see Problem 1.11). However, we must beware of choosing q to
be too large, since if mt is not linear, the filtered process, although smooth, will not
be a good estimate of mt . By clever choice of the weights {aj } it is possible (see
Problems 1.12–1.14 and Section 4.3) to design a filter that will not only be effective
in attenuating noise in the data, but that will also allow a larger class of trend functions
(for example all polynomials of degree less than or equal to 3) to pass through without
distortion. The Spencer 15-point moving average is a filter that passes polynomials
of degree 3 without distortion. Its weights are

aj � 0, |j | > 7,

with

aj � a−j , |j | ≤ 7,

and

[a0, a1, . . . , a7] � 1
320

[74, 67, 46, 21, 3,−5,−6,−3]. (1.5.6)

Applied to the process (1.5.2) with mt � c0 + c1t + c2t
2 + c3t

3, it gives

7∑
j�−7

ajXt−j �
7∑

j�−7

ajmt−j +
7∑

j�−7

ajYt−j ≈
7∑

j�−7

ajmt−j � mt,

where the last step depends on the assumed form ofmt (Problem 1.12). Further details
regarding this and other smoothing filters can be found in Kendall and Stuart (1976),
Chapter 46.

(b) Exponential smoothing. For any fixed α ∈ [0, 1], the one-sided moving
averages m̂t , t � 1, . . . , n, defined by the recursions

m̂t � αXt + (1 − α)m̂t−1, t � 2, . . . , n, (1.5.7)

and

m̂1 � X1 (1.5.8)
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can be computed using ITSM by selecting Smooth>Exponential and specifying
the value of α. Application of (1.5.7) and (1.5.8) is often referred to as exponential
smoothing, since the recursions imply that for t ≥ 2, m̂t �

∑t−2
j�0 α(1 − α)jXt−j +

(1 − α)t−1X1, a weighted moving average of Xt,Xt−1, . . ., with weights decreasing
exponentially (except for the last one).

(c) Smoothing by elimination of high-frequency components. The option
Smooth>FFT in the program ITSM allows us to smooth an arbitrary series by elimi-
nation of the high-frequency components of its Fourier series expansion (see Section
4.2). This option was used in Example 1.1.4, where we chose to retain the fraction
f � .035 of the frequency components of the series in order to estimate the underlying
signal. (The choice f � 1 would have left the series unchanged.)

Example 1.5.2 In Figures 1.21 and 1.22 we show the results of smoothing the strike data by ex-
ponential smoothing with parameter α � 0.4 (see (1.5.7)) and by high-frequency
elimination with f � 0.4, i.e., by eliminating a fraction 0.6 of the Fourier compo-
nents at the top of the frequency range. These should be compared with the simple
5-term moving average smoothing shown in Figure 1.18. Experimentation with dif-
ferent smoothing parameters can easily be carried out using the program ITSM. The
exponentially smoothed value of the last observation is frequently used to forecast
the next data value. The program automatically selects an optimal value of α for this
purpose if α is specified as −1 in the exponential smoothing dialog box.

(d) Polynomial fitting. In Section 1.3.2 we showed how a trend of the form
mt � a0 +a1t +a2t

2 can be fitted to the data {x1, . . . , xn} by choosing the parameters

Figure 1-21
Exponentially smoothed
strike data with α � 0.4.  
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Figure 1-22
Strike data smoothed
by elimination of high

frequencies with f � 0.4.  
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a0, a1, and a2 to minimize the sum of squares,
∑n

t�1(xt −mt)
2 (see Example 1.3.4).

The method of least squares estimation can also be used to estimate higher-order
polynomial trends in the same way. The Regression option of ITSM allows least
squares fitting of polynomial trends of order up to 10 (together with up to four har-
monic terms; see Example 1.3.6). It also allows generalized least squares estimation
(see Section 6.6), in which correlation between the residuals is taken into account.

Method 2: Trend Elimination by Differencing
Instead of attempting to remove the noise by smoothing as in Method 1, we now
attempt to eliminate the trend term by differencing. We define the lag-1 difference
operator ∇ by

∇Xt � Xt −Xt−1 � (1 − B)Xt, (1.5.9)

where B is the backward shift operator,

BXt � Xt−1. (1.5.10)

Powers of the operators B and ∇ are defined in the obvious way, i.e., Bj(Xt) � Xt−j
and ∇j (Xt) � ∇(∇j−1(Xt)), j ≥ 1, with ∇0(Xt) � Xt . Polynomials in B and ∇ are
manipulated in precisely the same way as polynomial functions of real variables. For
example,

∇2Xt � ∇(∇(Xt)) � (1 − B)(1 − B)Xt � (1 − 2B + B2)Xt

� Xt − 2Xt−1 +Xt−2.
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If the operator ∇ is applied to a linear trend functionmt � c0+c1t , then we obtain the
constant function ∇mt � mt −mt−1 � c0 + c1t − (c0 + c1(t − 1)) � c1. In the same
way any polynomial trend of degree k can be reduced to a constant by application of
the operator ∇k (Problem 1.10). For example, ifXt � mt+Yt , wheremt �

∑k

j�0 cj t
j

and Yt is stationary with mean zero, application of ∇k gives

∇kXt � k!ck + ∇kYt ,

a stationary process with mean k!ck. These considerations suggest the possibility,
given any sequence {xt} of data, of applying the operator ∇ repeatedly until we find
a sequence

{∇kxt
}

that can plausibly be modeled as a realization of a stationary
process. It is often found in practice that the order k of differencing required is quite
small, frequently one or two. (This relies on the fact that many functions can be
well approximated, on an interval of finite length, by a polynomial of reasonably low
degree.)

Example 1.5.3 Applying the operator∇ to the population values {xt , t � 1, . . . , 20} of Figure 1.5, we
find that two differencing operations are sufficient to produce a series with no apparent
trend. (To carry out the differencing using ITSM, select Transform>Difference,
enter the value 1 for the differencing lag, and click OK.) This replaces the original
series {xt} by the once-differenced series {xt − xt−1}. Repetition of these steps gives
the twice-differenced series ∇2xt � xt − 2xt−1 + xt−2, plotted in Figure 1.23. Notice
that the magnitude of the fluctuations in∇2xt increases with the value of xt . This effect
can be suppressed by first taking natural logarithms, yt � ln xt , and then applying the
operator ∇2 to the series {yt}. (See also Figures 1.1 and 1.17.)

Figure 1-23
The twice-differenced series
derived from the population

data of Figure 1.5.  
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1.5.2 Estimation and Elimination of Both Trend and Seasonality

The methods described for the estimation and elimination of trend can be adapted in
a natural way to eliminate both trend and seasonality in the general model, specified
as follows.

Classical Decomposition Model

Xt � mt + st + Yt , t � 1, . . . , n, (1.5.11)

where EYt � 0, st+d � st , and
∑d

j�1 sj � 0.

We shall illustrate these methods with reference to the accidental deaths data of
Example 1.1.3, for which the period d of the seasonal component is clearly 12.

Method S1: Estimation of Trend and Seasonal Components
The method we are about to describe is used in the Transform>Classical option
of ITSM.

Suppose we have observations {x1, . . . , xn}. The trend is first estimated by ap-
plying a moving average filter specially chosen to eliminate the seasonal component
and to dampen the noise. If the period d is even, say d � 2q, then we use

m̂t � (0.5xt−q + xt−q+1 + · · · + xt+q−1 + 0.5xt+q)/d, q < t ≤ n− q. (1.5.12)

If the period is odd, say d � 2q + 1, then we use the simple moving average (1.5.5).
The second step is to estimate the seasonal component. For each k � 1, . . . , d, we

compute the averagewk of the deviations {(xk+jd−m̂k+jd), q < k+jd ≤ n−q}. Since
these average deviations do not necessarily sum to zero, we estimate the seasonal
component sk as

ŝk � wk − d−1
d∑
i�1

wi, k � 1, . . . , d, (1.5.13)

and ŝk � ŝk−d, k > d.
The deseasonalized data is then defined to be the original series with the estimated

seasonal component removed, i.e.,

dt � xt − ŝt , t � 1, . . . , n. (1.5.14)

Finally, we reestimate the trend from the deseasonalized data {dt} using one of
the methods already described. The program ITSM allows you to fit a least squares
polynomial trend m̂ to the deseasonalized series. In terms of this reestimated trend
and the estimated seasonal component, the estimated noise series is then given by

Ŷt � xt − m̂t − ŝt , t � 1, . . . , n.
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The reestimation of the trend is done in order to have a parametric form for the trend
that can be extrapolated for the purposes of prediction and simulation.

Example 1.5.4 Figure 1.24 shows the deseasonalized accidental deaths data obtained from ITSM
by reading in the series DEATHS.TSM, selecting Transform>Classical, check-
ing only the box marked Seasonal Fit, entering 12 for the period, and clicking
OK. The estimated seasonal component ŝt , shown in Figure 1.25, is obtained by se-
lecting Transform>Show Classical Fit. (Except for having a mean of zero, this
estimate is very similar to the harmonic regression function with frequencies 2π/12
and 2π/6 displayed in Figure 1.11.) The graph of the deseasonalized data suggests
the presence of an additional quadratic trend function. In order to fit such a trend to
the deseasonalized data, select Transform>Undo Classical to retrieve the original
data and then select Transform>Classical and check the boxes marked Seasonal
Fit and Polynomial Trend, entering 12 for the period and selecting Quadratic
for the trend. Then click OK and you will obtain the trend function

m̂t � 9952 − 71.82t + 0.8260t2, 1 ≤ t ≤ 72.

At this point the data stored in ITSM consists of the estimated noise

Ŷt � xt − m̂t − ŝt , t � 1, . . . , 72,

obtained by subtracting the estimated seasonal and trend components from the original
data.

Figure 1-24
The deseasonalized
accidental deaths
data from ITSM.  
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Figure 1-25
The estimated seasonal

component of the
accidental deaths
data from ITSM.  
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Method S2: Elimination of Trend and Seasonal Components by Differencing
The technique of differencing that we applied earlier to nonseasonal data can be
adapted to deal with seasonality of period d by introducing the lag-d differencing
operator ∇d defined by

∇dXt � Xt −Xt−d � (1 − Bd)Xt . (1.5.15)

(This operator should not be confused with the operator ∇d � (1 − B)d defined
earlier.)

Applying the operator ∇d to the model

Xt � mt + st + Yt ,

where {st} has period d, we obtain

∇dXt � mt −mt−d + Yt − Yt−d,

which gives a decomposition of the difference ∇dXt into a trend component (mt −
mt−d) and a noise term (Yt−Yt−d). The trend,mt−mt−d , can then be eliminated using
the methods already described, in particular by applying a power of the operator ∇.

Example 1.5.5 Figure 1.26 shows the result of applying the operator ∇12 to the accidental deaths
data. The graph is obtained from ITSM by opening DEATHS.TSM, selecting Trans-
form>Difference, entering lag 12, and clicking OK. The seasonal component evident
in Figure 1.3 is absent from the graph of ∇12xt , 13 ≤ t ≤ 72. However, there still
appears to be a nondecreasing trend. If we now apply the operator ∇ to {∇12xt} by
again selecting Transform>Difference, this time with lag one, we obtain the graph



The Bartlett Press, Inc. brockwel 2 · v · 2002 9:02 a.m. Page 34

34 Chapter 1 Introduction

Figure 1-26
The differenced series
{∇12xt , t � 13, . . . ,72}

derived from the monthly
accidental deaths

{xt , t � 1, . . . ,72}.  
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of ∇∇12xt , 14 ≤ t ≤ 72, shown in Figure 1.27, which has no apparent trend or sea-
sonal component. In Chapter 5 we shall show that this doubly differenced series can
in fact be well represented by a stationary time series model.

In this section we have discussed a variety of methods for estimating and/or
removing trend and seasonality. The particular method chosen for any given data
set will depend on a number of factors including whether or not estimates of the

Figure 1-27
The differenced series

{∇∇12xt , t � 14, . . . ,72}
derived from the monthly

accidental deaths
{xt , t � 1, . . . ,72}.
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components of the series are required and whether or not it appears that the data
contain a seasonal component that does not vary with time. The program ITSM
allows two options under the Transform menu:

1. “classical decomposition,” in which trend and/or seasonal components are esti-
mated and subtracted from the data to generate a noise sequence, and

2. “differencing,” in which trend and/or seasonal components are removed from the
data by repeated differencing at one or more lags in order to generate a noise
sequence.

A third option is to use the Regression menu, possibly after applying a Box–Cox
transformation. Using this option we can (see Example 1.3.6)

3. fit a sum of harmonics and a polynomial trend to generate a noise sequence that
consists of the residuals from the regression.

In the next section we shall examine some techniques for deciding whether or not the
noise sequence so generated differs significantly from iid noise. If the noise sequence
does have sample autocorrelations significantly different from zero, then we can take
advantage of this serial dependence to forecast future noise values in terms of past
values by modeling the noise as a stationary time series.

1.6 Testing the Estimated Noise Sequence

The objective of the data transformations described in Section 1.5 is to produce a
series with no apparent deviations from stationarity, and in particular with no apparent
trend or seasonality. Assuming that this has been done, the next step is to model the
estimated noise sequence (i.e., the residuals obtained either by differencing the data
or by estimating and subtracting the trend and seasonal components). If there is no
dependence among between these residuals, then we can regard them as observations
of independent random variables, and there is no further modeling to be done except to
estimate their mean and variance. However, if there is significant dependence among
the residuals, then we need to look for a more complex stationary time series model
for the noise that accounts for the dependence. This will be to our advantage, since
dependence means in particular that past observations of the noise sequence can assist
in predicting future values.

In this section we examine some simple tests for checking the hypothesis that
the residuals from Section 1.5 are observed values of independent and identically
distributed random variables. If they are, then our work is done. If not, then we must
use the theory of stationary processes to be developed in later chapters to find a more
appropriate model.
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(a) The sample autocorrelation function. For large n, the sample autocorre-
lations of an iid sequence Y1, . . . , Yn with finite variance are approximately iid with
distribution N(0, 1/n) (see TSTM p. 222). Hence, if y1, . . . , yn is a realization of
such an iid sequence, about 95% of the sample autocorrelations should fall between
the bounds ±1.96/

√
n. If we compute the sample autocorrelations up to lag 40 and

find that more than two or three values fall outside the bounds, or that one value falls
far outside the bounds, we therefore reject the iid hypothesis. The bounds ±1.96/

√
n

are automatically plotted when the sample autocorrelation function is computed by
the program ITSM.

(b) The portmanteau test. Instead of checking to see whether each sample
autocorrelation ρ̂(j) falls inside the bounds defined in (a) above, it is also possible
to consider the single statistic

Q � n

h∑
j�1

ρ̂2(j).

If Y1, . . . , Yn is a finite-variance iid sequence, then by the same result used in (a), Q is
approximately distributed as the sum of squares of the independent N(0, 1) random
variables,

√
nρ̂(j), j � 1, . . . , h, i.e., as chi-squared with h degrees of freedom. A

large value of Q suggests that the sample autocorrelations of the data are too large for
the data to be a sample from an iid sequence. We therefore reject the iid hypothesis
at level α if Q > χ 2

1−α(h), where χ 2
1−α(h) is the 1 − α quantile of the chi-squared

distribution with h degrees of freedom. The program ITSM conducts a refinement of
this test, formulated by Ljung and Box (1978), in which Q is replaced by

QLB � n(n+ 2)
h∑

j�1

ρ̂2(j)/(n− j),

whose distribution is better approximated by the chi-squared distribution with h

degrees of freedom.
Another portmanteau test, formulated by McLeod and Li (1983), can be used as

a further test for the iid hypothesis, since if the data are iid, then the squared data are
also iid. It is based on the same statistic used for the Ljung–Box test, except that the
sample autocorrelations of the data are replaced by the sample autocorrelations of
the squared data, ρ̂WW (h), giving

QML � n(n+ 2)
h∑

k�1

ρ̂2
WW(k)/(n− k).

The hypothesis of iid data is then rejected at level α if the observed value of QML is
larger than the 1 − α quantile of the χ 2(h) distribution.

(c) The turning point test. If y1, . . . , yn is a sequence of observations, we say
that there is a turning point at time i, 1 < i < n, if yi−1 < yi and yi > yi+1 or if
yi−1 > yi and yi < yi+1. If T is the number of turning points of an iid sequence of
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length n, then, since the probability of a turning point at time i is 2
3 , the expected

value of T is

µT � E(T ) � 2(n− 2)/3.

It can also be shown for an iid sequence that the variance of T is

σ 2
T � Var(T ) � (16n− 29)/90.

A large value of T − µT indicates that the series is fluctuating more rapidly than
expected for an iid sequence. On the other hand, a value of T − µT much smaller
than zero indicates a positive correlation between neighboring observations. For an
iid sequence with n large, it can be shown that

T is approximately N
(
µT , σ

2
T

)
.

This means we can carry out a test of the iid hypothesis, rejecting it at level α if
|T −µT |/σT > 41−α/2, where 41−α/2 is the 1 − α/2 quantile of the standard normal
distribution. (A commonly used value of α is .05, for which the corresponding value
of 41−α/2 is 1.96.)

(d) The difference-sign test. For this test we count the number S of values of i
such that yi > yi−1, i � 2, . . . , n, or equivalently the number of times the differenced
series yi − yi−1 is positive. For an iid sequence it is clear that

µS � ES � 1
2
(n− 1).

It can also be shown, under the same assumption, that

σ 2
S � Var(S) � (n+ 1)/12,

and that for large n,

S is approximately N
(
µS, σ

2
S

)
.

A large positive (or negative) value of S−µS indicates the presence of an increasing
(or decreasing) trend in the data. We therefore reject the assumption of no trend in
the data if |S − µS |/σS > 41−α/2.

The difference-sign test must be used with caution. A set of observations exhibit-
ing a strong cyclic component will pass the difference-sign test for randomness, since
roughly half of the observations will be points of increase.

(e) The rank test. The rank test is particularly useful for detecting a linear trend
in the data. Define P to be the number of pairs (i, j) such that yj > yi and j > i,
i � 1, . . . , n− 1. There is a total of

(
n

2

) � 1
2n(n− 1) pairs (i, j) such that j > i. For

an iid sequence {Y1, . . . , Yn}, each event {Yj > Yi} has probability 1
2 , and the mean

of P is therefore

µP � 1
4
n(n− 1).
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It can also be shown for an iid sequence that the variance of P is

σ 2
P � n(n− 1)(2n+ 5)/72

and that for large n,

P is approximately N
(
µP , σ

2
P

)
(see Kendall and Stuart, 1976). A large positive (negative) value of P −µP indicates
the presence of an increasing (decreasing) trend in the data. The assumption that
{yj } is a sample from an iid sequence is therefore rejected at level α � 0.05 if
|P − µP |/σP > 41−α/2 � 1.96.

(f) Fitting an autoregressive model. A further test that can be carried out using
the program ITSM is to fit an autoregressive model to the data using the Yule–Walker
algorithm (discussed in Section 5.1.1) and choosing the order which minimizes the
AICC statistic (see Section 5.5). A selected order equal to zero suggests that the data
is white noise.

(g) Checking for normality. If the noise process is Gaussian, i.e., if all of its
joint distributions are normal, then stronger conclusions can be drawn when a model
is fitted to the data. The following test enables us to check whether it is reasonable
to assume that observations from an iid sequence are also Gaussian.

Let Y(1) < Y(2) < · · · < Y(n) be the order statistics of a random sample Y1, . . . , Yn
from the distribution N(µ, σ 2). If X(1) < X(2) < · · · < X(n) are the order statistics
from a N(0, 1) sample of size n, then

EY(j) � µ+ σmj ,

where mj � EX(j), j � 1, . . . , n. The graph of the points
(
m1, Y(1)), . . . , (mn, Y(n)

)
is called a Gaussian qq plot) and can be displayed in ITSM by clicking on the yellow
button labeled QQ. If the normal assumption is correct, the Gaussian qq plot should be
approximately linear. Consequently, the squared correlation of the points (mi, Y(i)),
i � 1, . . . , n, should be near 1. The assumption of normality is therefore rejected if the
squared correlation R2 is sufficiently small. If we approximate mi by 4−1((i− .5)/n)
(see Mage, 1982 for some alternative approximations), then R2 reduces to

R2 �
(∑n

i�1(Y(i) − Y )4−1
(
i−.5
n

))2∑n

i�1(Y(i) − Y )2
∑n

i�1

(
4−1

(
i−.5
n

))2 ,

where Y � n−1(Y1 +· · ·+Yn). Percentage points for the distribution of R2, assuming
normality of the sample values, are given by Shapiro and Francia (1972) for sample
sizes n < 100. For n � 200, P(R2 < .987) � .05 and P(R2 < .989) � .10. For
larger values of n the Jarque-Bera test for normality can be used (see Section 5.3.3).

Example 1.6.1 If we did not know in advance how the signal plus noise data of Example 1.1.4 were
generated, we might suspect that they came from an iid sequence. We can check this
hypothesis with the aid of the tests (a)–(f) introduced above.
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(a) The sample autocorrelation function (Figure 1.28) is obtained from ITSM by
opening the project SIGNAL.TSM and clicking on the second yellow button at the
top of the ITSM window. Observing that 25% of the autocorrelations are outside the
bounds ±1.96/

√
200, we reject the hypothesis that the series is iid.

The remaining tests (b), (c), (d), (e), and (f) are performed by choosing the option
Statistics>Residual Analysis>Tests of Randomness. (Since no model has
been fitted to the data, the residuals are the same as the data themselves.)

(b) The sample value of the Ljung–Box statistic QLB with h � 20 is 51.84. Since
the corresponding p-value (displayed by ITSM) is .00012 < .05, we reject the iid
hypothesis at level .05. The p-value for the McLeod–Li statistic QML is 0.717. The
McLeod–Li statistic does therefore not provide sufficient evidence to reject the iid
hypothesis at level .05.

(c) The sample value of the turning-point statistic T is 138, and the asymptotic
distribution under the iid hypothesis (with sample size n � 200) is N(132, 35.3). Thus
|T − µT |/σT � 1.01, corresponding to a computed p-value of .312. On the basis of
the value of T there is therefore not sufficient evidence to reject the iid hypothesis at
level .05.

(d) The sample value of the difference-sign statistic S is 101, and the asymptotic
distribution under the iid hypothesis (with sample size n � 200) is N(99.5, 16.7).
Thus |S−µS |/σS � 0.38, corresponding to a computedp-value of 0.714. On the basis
of the value of S there is therefore not sufficient evidence to reject the iid hypothesis
at level .05.

Figure 1-28
The sample autocorrelation

function for the data of
Example 1.1.4 showing
the bounds ±1.96/√n.
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(e) The sample value of the rank statistic P is 10310, and the asymptotic dis-
tribution under the iid hypothesis (with n � 200) is N

(
9950, 2.239 × 105

)
. Thus

|P −µP |/σP � 0.76, corresponding to a computed p-value of 0.447. On the basis of
the value of P there is therefore not sufficient evidence to reject the iid hypothesis at
level .05.

(f) The minimum-AICC Yule–Walker autoregressive model for the data is of
order seven, supporting the evidence provided by the sample ACF and Ljung–Box
tests against the iid hypothesis.

Thus, although not all of the tests detect significant deviation from iid behavior,
the sample autocorrelation, the Ljung–Box statistic, and the fitted autoregression pro-
vide strong evidence against it, causing us to reject it (correctly) in this example.

The general strategy in applying the tests described in this section is to check
them all and to proceed with caution if any of them suggests a serious deviation
from the iid hypothesis. (Remember that as you increase the number of tests, the
probability that at least one rejects the null hypothesis when it is true increases. You
should therefore not necessarily reject the null hypothesis on the basis of one test
result only.)

Problems

1.1. Let X and Y be two random variables with E(Y ) � µ and EY 2 < ∞.

a. Show that the constant c that minimizes E(Y − c)2 is c � µ.

b. Deduce that the random variable f (X) that minimizes E
[
(Y −f (X))2|X] is

f (X) � E[Y |X].

c. Deduce that the random variable f (X) that minimizes E(Y −f (X))2 is also

f (X) � E[Y |X].

1.2. (Generalization of Problem 1.1.) Suppose that X1, X2, . . . is a sequence of ran-
dom variables with E(X2

t ) < ∞ and E(Xt) � µ.

a. Show that the random variable f (X1, . . . , Xn) that minimizes E
[
(Xn+1 −

f (X1, . . . , Xn))
2|X1, . . . , Xn

]
is

f (X1, . . . , Xn) � E[Xn+1|X1, . . . , Xn].

b. Deduce that the random variable f (X1, . . . , Xn) that minimizes E
[
(Xn+1 −

f (X1, . . . , Xn))
2
]

is also

f (X1, . . . , Xn) � E[Xn+1|X1, . . . , Xn].

c. If X1, X2, . . . is iid with E(X2
i ) < ∞ and EXi � µ, where µ is known, what

is the minimum mean squared error predictor ofXn+1 in terms ofX1, . . . , Xn?
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d. Under the conditions of part (c) show that the best linear unbiased estimator
of µ in terms of X1, . . . , Xn is X̄ � 1

n
(X1 + · · · + Xn). (µ̂ said to be an

unbiased estimator of µ if Eµ̂ � µ for all µ.)

e. Under the conditions of part (c) show that X̄ is the best linear predictor of
Xn+1 that is unbiased for µ.

f. If X1, X2, . . . is iid with E
(
X2

i

)
< ∞ and EXi � µ, and if S0 � 0, Sn �

X1 + · · · + Xn, n � 1, 2, . . ., what is the minimum mean squared error
predictor of Sn+1 in terms of S1, . . . , Sn?

1.3. Show that a strictly stationary process with E(X2
i ) < ∞ is weakly stationary.

1.4. Let {Zt} be a sequence of independent normal random variables, each with
mean 0 and variance σ 2, and let a, b, and c be constants. Which, if any, of
the following processes are stationary? For each stationary process specify the
mean and autocovariance function.

a. Xt � a + bZt + cZt−2

b. Xt � Z1 cos(ct)+ Z2 sin(ct)

c. Xt � Zt cos(ct)+ Zt−1 sin(ct)

d. Xt � a + bZ0

e. Xt � Z0 cos(ct)

f. Xt � ZtZt−1

1.5. Let {Xt} be the moving-average process of order 2 given by

Xt � Zt + θZt−2,

where {Zt} is WN(0, 1).

a. Find the autocovariance and autocorrelation functions for this process when
θ � .8.

b. Compute the variance of the sample mean (X1 + X2 + X3 + X4)/4 when
θ � .8.

c. Repeat (b) when θ � −.8 and compare your answer with the result obtained
in (b).

1.6. Let {Xt} be the AR(1) process defined in Example 1.4.5.

a. Compute the variance of the sample mean (X1 + X2 + X3 + X4)/4 when
φ � .9 and σ 2 � 1.

b. Repeat (a) when φ � −.9 and compare your answer with the result obtained
in (a).

1.7. If {Xt} and {Yt} are uncorrelated stationary sequences, i.e., if Xr and Ys are
uncorrelated for every r and s, show that {Xt + Yt} is stationary with autoco-
variance function equal to the sum of the autocovariance functions of {Xt} and
{Yt}.
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1.8. Let {Zt} be IID N(0, 1) noise and define

Xt �
{
Zt, if t is even,

(Z2
t−1 − 1)/

√
2, if t is odd.

a. Show that {Xt} is WN(0, 1) but not iid(0, 1) noise.

b. Find E(Xn+1|X1, . . . , Xn) for n odd and n even and compare the results.

1.9. Let {x1, . . . , xn} be observed values of a time series at times 1, . . . , n, and let
ρ̂(h) be the sample ACF at lag h as in Definition 1.4.4.

a. If xt � a + bt , where a and b are constants and b �� 0, show that for each
fixed h ≥ 1,

ρ̂(h) → 1 as n → ∞.

b. If xt � c cos(ωt), where c and ω are constants (c �� 0 and ω ∈ (−π, π]),
show that for each fixed h,

ρ̂(h) → cos(ωh) as n → ∞.

1.10. If mt �
∑p

k�0 ckt
k, t � 0,±1, . . . , show that ∇mt is a polynomial of degree

p − 1 in t and hence that ∇p+1mt � 0.

1.11. Consider the simple moving-average filter with weights aj � (2q+1)−1, −q ≤
j ≤ q.

a. If mt � c0 + c1t , show that
∑q

j�−q ajmt−j � mt .

b. IfZt, t � 0,±1,±2, . . . , are independent random variables with mean 0 and
variance σ 2, show that the moving average At �

∑q

j�−q ajZt−j is “small”
for large q in the sense that EAt � 0 and Var(At) � σ 2/(2q + 1).

1.12. a. Show that a linear filter {aj } passes an arbitrary polynomial of degree k

without distortion, i.e., that

mt �
∑
j

ajmt−j

for all kth-degree polynomials mt � c0 + c1t + · · · + ckt
k, if and only if

∑
j

aj � 1 and

∑
j

j raj � 0, for r � 1, . . . , k.

b. Deduce that the Spencer 15-point moving-average filter {aj } defined by
(1.5.6) passes arbitrary third-degree polynomial trends without distortion.
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1.13. Find a filter of the form 1 + αB + βB2 + γB3 (i.e., find α, β, and γ ) that
passes linear trends without distortion and that eliminates arbitrary seasonal
components of period 2.

1.14. Show that the filter with coefficients [a−2, a−1, a0, a1, a2] � 1
9 [−1, 4, 3, 4,−1]

passes third-degree polynomials and eliminates seasonal components with pe-
riod 3.

1.15. Let {Yt} be a stationary process with mean zero and let a and b be constants.

a. If Xt � a + bt + st + Yt , where st is a seasonal component with period
12, show that ∇∇12Xt � (1 − B)(1 − B12)Xt is stationary and express its
autocovariance function in terms of that of {Yt}.

b. If Xt � (a + bt)st + Yt , where st is a seasonal component with period 12,
show that ∇2

12Xt � (1−B12)2Xt is stationary and express its autocovariance
function in terms of that of {Yt}.

1.16. (Using ITSM to smooth the strikes data.) Double-click on the ITSM icon, select
File>Project>Open>Univariate, click OK, and open the file STRIKES.
TSM. The graph of the data will then appear on your screen. To smooth the
data select Smooth>Moving Ave, Smooth>Exponential, or Smooth>FFT. Try
using each of these to reproduce the results shown in Figures 1.18, 1.21, and
1.22.

1.17. (Using ITSM to plot the deaths data.) In ITSM select File>Project>Open>
Univariate, click OK, and open the project DEATHS.TSM. The graph of
the data will then appear on your screen. To see a histogram of the data, click
on the sixth yellow button at the top of the ITSM window. To see the sample
autocorrelation function, click on the second yellow button. The presence of a
strong seasonal component with period 12 is evident in the graph of the data
and in the sample autocorrelation function.

1.18. (Using ITSM to analyze the deaths data.) Open the file DEATHS.TSM, select
Transform>Classical, check the box marked Seasonal Fit, and enter 12
for the period. Make sure that the box labeled Polynomial Fit is not checked,
and click, OK. You will then see the graph (Figure 1.24) of the deseasonalized
data. This graph suggests the presence of an additional quadratic trend function.
To fit such a trend to the deseasonalized data, select Transform>Undo Clas-
sical to retrieve the original data. Then select Transform>Classical and
check the boxes marked Seasonal Fit and Polynomial Trend, entering 12
for the period and Quadratic for the trend. Click OK and you will obtain the
trend function

m̂t � 9952 − 71.82t + 0.8260t2, 1 ≤ t ≤ 72.
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At this point the data stored in ITSM consists of the estimated noise

Ŷt � xt − m̂t − ŝt , t � 1, . . . , 72,

obtained by subtracting the estimated seasonal and trend components from the
original data. The sample autocorrelation function can be plotted by clicking
on the second yellow button at the top of the ITSM window. Further tests for
dependence can be carried out by selecting the options Statistics>Residual
Analysis>Tests of Randomness. It is clear from these that there is substan-
tial dependence in the series {Yt}.

To forecast the data without allowing for this dependence, select the option Fore-
casting>ARMA. Specify 24 for the number of values to be forecast, and the program
will compute forecasts based on the assumption that the estimated seasonal and trend
components are true values and that {Yt} is a white noise sequence with zero mean.
(This is the default model assumed by ITSM until a more complicated stationary
model is estimated or specified.) The original data are plotted with the forecasts
appended.

Later we shall see how to improve on these forecasts by taking into account the
dependence in the series {Yt}.
1.19. Use a text editor, e.g., WORDPAD or NOTEPAD, to construct and save a

text file named TEST.TSM, which consists of a single column of 30 numbers,
{x1, . . . , x30}, defined by

x1, . . . , x10 : 486, 474, 434, 441, 435, 401, 414, 414, 386, 405;
x11, . . . , x20 : 411, 389, 414, 426, 410, 441, 459, 449, 486, 510;
x21, . . . , x30 : 506, 549, 579, 581, 630, 666, 674, 729, 771, 785.

This series is in fact the sum of a quadratic trend and a period-three seasonal
component. Use the program ITSM to apply the filter in Problem 1.14 to this
time series and discuss the results.

(Once the data have been typed, they can be imported directly into ITSM by
coping and pasting to the clipboard, and then in ITSM selecting File>Project>New>
Univariate, clicking on OK and selecting File>Import Clipboard.)
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