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The package ITSM2000, the student version of which is included with this book,
requires an IBM-compatible PC operating under Windows 95, NT, version 4.0 or a
later version of either of these operating systems. To install the package, copy the
folder ITSM2000 from the CD-ROM to any convenient location on your hard disk.
To run the program, you can either double-click on the icon ITSM.EXE in the folder
ITSM2000 or, on the Windows task bar, left-click on Start, select Run, enter the
location and name of the file ITSM.EXE (e.g. C:\ITSM2000\ITSM.EXE) and click
on OK. You may find it convenient to create a shortcut on your desktop by right-
clicking on the ITSM.EXE icon and selecting Create shortcut. Then right-click
on the shortcut icon, drag it to your desktop, and select Move here. The program
can then be run at any time by double-clicking on the shortcut icon. The program
can also be run directly from the CD-ROM by opening the folder ITSM2000 and
double-clicking on the icon ITSM.EXE. The package ITSM2000 supersedes earlier
versions of the package ITSM distributed with this book.
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D.1 Getting Started

D.1.1 Running ITSM

Double-click on the icon labeled ITSM.EXE, and the ITSM window will open. Se-
lecting the option Help>Contents will show you the topics for which explanations
and examples are provided. Clicking on Index at the top of the Help window will
allow you to find more specific topics. Close the Help window by clicking on the
X at its top right corner. To begin analyzing one of the data sets provided, select
File>Project>Open at the top left corner of the ITSM window.

There are several distinct functions of the program ITSM. The first is to analyze
and display the properties of time series data, the second is to compute and display the
properties of time series models, and the third is to combine these functions in order
to fit models to data. The last of these includes checking that the properties of the
fitted model match those of the data in a suitable sense. Having found an appropriate
model, we can (for example) then use it in conjunction with the data to forecast future
values of the series. Sections D.2–D.5 of this appendix deal with the modeling and
analysis of data, while Section D.6 is concerned with model properties. Section D.7
explains how to open multivariate projects in ITSM. Examples of the analysis of
multivariate time series are given in Chapter 7.

It is important to keep in mind the distinction between data and model properties
and not to confuse the data with the model. In any one project ITSM stores one data
set and one model (which can be identified by highlighting the project window and
pressing the red INFO button at the top of the ITSM window). Until a model is entered
by the user, ITSM stores the default model of white noise with variance 1. If the data
are transformed (e.g., differenced and mean-corrected), then the data are replaced
in ITSM by the transformed data. (The original data can, however, be restored by
inverting the transformations.) Rarely (if ever) is a real time series generated by a
model as simple as those used for fitting purposes. In model fitting the objective is to
develop a model that mimics important features of the data, but is still simple enough
to be used with relative ease.

The following sections constitute a tutorial that illustrates the use of some of
the features of ITSM by leading you through a complete analysis of the well-known
airline passenger series of Box and Jenkins (1976) filed as AIRPASS.TSM in the
ITSM2000 folder.

D.2 Preparing Your Data for Modeling

The observed values of your time series should be available in a single-column ASCII
file (or two columns for a bivariate series). The file, like those provided with the pack-
age, should be given a name with suffix .TSM. You can then begin model fitting with
ITSM. The program will read your data from the file, plot it on the screen, compute
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sample statistics, and allow you to make a number of transformations designed to
make your transformed data representable as a realization of a zero-mean stationary
process.

Example D.2.1 To illustrate the analysis we shall use the file AIRPASS.TSM, which contains the
number of international airline passengers (in thousands) for each month from Jan-
uary, 1949, through December, 1960.

D.2.1 Entering Data

Once you have opened the ITSM window as described above under Getting Started,
select the options File>Project>Open, and you will see a dialog box in which you
can check either Univariate or Multivariate. Since the data set for this example
is univariate, make sure that the univariate option is checked and then click OK.
A window labeled Open File will then appear, in which you can either type the
name AIRPASS.TSM and click Open, or else locate the icon for AIRPASS.TSM
in the Open File window and double-click on it. You will then see a graph of the
monthly international airline passenger totals (measured in thousands) X1, . . . , Xn,
with n � 144. Directly behind the graph is a window containing data summary
statistics.

An additional, second, project can be opened by repeating the procedure described
in the preceding paragraph. Alternatively, the data can be replaced in the current
project using the option File>Import File. This option is useful if you wish to
examine how well a fitted model represents a different data set. (See the entryProject
Editor in the ITSM Help Files for information on multiple project management. Each
ITSM project has its own data set and model.) For the purpose of this introduction
we shall open only one project.

D.2.2 Information

If, with the window labeled AIRPASS.TSM highlighted, you press the red INFO
button at the top of the ITSM window, you will see the sample mean, sample variance,
estimated standard deviation of the sample mean, and the current model (white noise
with variance 1).

Example D.2.2 Go through the steps in Entering Data to open the project AIRPASS.TSM and use
the INFO button to determine the sample mean and variance of the series.

D.2.3 Filing Data

You may wish to transform your data using ITSM and then store it in another file. At
any time before or after transforming the data in ITSM, the data can be exported to a
file by clicking on the red Export button, selecting Time Series and File, clicking
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OK, and specifying a new file name. The numerical values of the series can also be
pasted to the clipboard (and from there into another document) in the same way by
choosing Clipboard instead of File. Other quantities computed by the program
(e.g., the residuals from the current model) can be filed or pasted to the clipboard in
the same way by making the appropriate selection in the Export dialog box. Graphs
can also be pasted to the clipboard by right-clicking on them and selecting Copy to
Clipboard.

Example D.2.3. Copy the series AIRPASS.TSM to the clipboard, open Wordpad or some convenient
screen editor, and choose Edit>Paste to insert the series into your new document.
Then copy the graph of the series to the clipboard and insert it into your document
in the same way.

D.2.4 Plotting Data

A time series graph is automatically plotted when you open a data file (with time
measured in units of the interval between observations, i.e., t � 1, 2, 3, . . .). To see
a histogram of the data press the rightmost yellow button at the top of the ITSM
screen. If you wish to adjust the number of bins in the histogram, select Statis-
tics>Histogram>Set Bin Count and specify the number of bins required. The
histogram will then be replotted accordingly.

To insert any of the ITSM graphs into a text document, right-click on the graph
concerned, select Copy to Clipboard, and the graph will be copied to the clipboard.
It can then be pasted into a document opened by any standard text editor such as MS-
Word or Wordpad using the Edit>Paste option in the screen editor. The graph can
also be sent directly to a printer by right-clicking on the graph and selecting Print.
Another useful graphics feature is provided by the white Zoom buttons at the top of
the ITSM screen. The first and second of these enable you to enlarge a designated
segment or box, respectively, of any of the graphs. The third button restores the
original graph.

Example D.2.4 Continuing with our analysis of AIRPASS.TSM, press the yellow histogram but-
ton to see a histogram of the data. Replot the histogram with 20 bins by selecting
Statistics>Histogram>Set Bin Count.

D.2.5 Transforming Data

Transformations are applied in order to produce data that can be successfully modeled
as “stationary time series.” In particular, they are used to eliminate trend and cyclic
components and to achieve approximate constancy of level and variability with time.

Example D.2.5. The airline passenger data (see Figure 9.4) are clearly not stationary. The level and
variability both increase with time, and there appears to be a large seasonal component
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(with period 12). They must therefore be transformed in order to be represented as
a realization of a stationary time series using one or more of the transformations
available for this purpose in ITSM.

Box–Cox Transformations

Box–Cox transformations are performed by selecting Transform>Box-Cox and
specifying the value of the Box–Cox parameter λ. If the original observations are
Y1, Y2, . . . , Yn, the Box–Cox transformation fλ converts them to fλ(Y1), fλ(Y2), . . . ,

fλ(Yn), where

fλ(y) �

yλ − 1
λ

, λ �� 0,

log(y), λ � 0.

These transformations are useful when the variability of the data increases or
decreases with the level. By suitable choice of λ, the variability can often be made
nearly constant. In particular, for positive data whose standard deviation increases
linearly with level, the variability can be stabilized by choosing λ � 0.

The choice of λ can be made visually by watching the graph of the data when
you click on the pointer in the Box–Cox dialog box and drag it back and forth along
the scale, which runs from zero to 1.5. Very often it is found that no transformation
is needed or that the choice λ � 0 is satisfactory.

Example D.2.6 For the series AIRPASS.TSM, the variability increases with level, and the data are
strictly positive. Taking natural logarithms (i.e., choosing a Box–Cox transformation
with λ � 0) gives the transformed data shown in Figure D.1.

Notice how the amplitude of the fluctuations no longer increases with the level of
the data. However, the seasonal effect remains, as does the upward trend. These will
be removed shortly. The data stored in ITSM now consist of the natural logarithms
of the original data.

Classical Decompositon

There are two methods provided in ITSM for the elimination of trend and seasonality.
These are:

i. “classical decomposition” of the series into a trend component, a seasonal com-
ponent, and a random residual component, and

ii. differencing.
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Figure D-1
The series AIRPASS.TSM

after taking logs.
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Classical decomposition of the series {Xt} is based on the model

Xt � mt + st + Yt ,

where Xt is the observation at time t , mt is a “trend component,” st is a “seasonal
component,” and Yt is a “random noise component,” which is stationary with mean
zero. The objective is to estimate the components mt and st and subtract them from
the data to generate a sequence of residuals (or estimated noise) that can then be
modeled as a stationary time series.

To achieve this, select Transform>Classical and you will see the Classical
Decomposition dialog box. To remove a seasonal component and trend, check the
Seasonal Fit and Polynomial Fit boxes, enter the period of the seasonal com-
ponent, and choose between the alternatives Quadratic Trend and Linear Trend.
Click OK, and the trend and seasonal components will be estimated and removed from
the data, leaving the estimated noise sequence stored as the current data set.

The estimated noise sequence automatically replaces the previous data stored in
ITSM.

Example D.2.7 The logged airline passenger data have an apparent seasonal component of period
12 (corresponding to the month of the year) and an approximately quadratic trend.
Remove these using the option Transform>Classical as described above. (An
alternative approach is to use the option Regression, which allows the specification
and fitting of polynomials of degree up to 10 and a linear combination of up to 4 sine
waves.)

Figure D.2 shows the transformed data (or residuals) Yt , obtained by removal
of trend and seasonality from the logged AIRPASS.TSM series by classical decom-
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Figure D-2
The logged AIRPASS.TSM

series after removal of trend
and seasonal components

by classical decomposition.
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position. {Yt} shows no obvious deviations from stationarity, and it would now be
reasonable to attempt to fit a stationary time series model to this series. To see how
well the estimated seasonal and trend components fit the data, selectTransform>Show
Classical Fit. We shall not pursue this approach any further here, but turn instead
to the differencing approach. (You should have no difficulty in later returning to this
point and completing the classical decomposition analysis by fitting a stationary time
series model to {Yt}.)

Differencing

Differencing is a technique that can also be used to remove seasonal components and
trends. The idea is simply to consider the differences between pairs of observations
with appropriate time separations. For example, to remove a seasonal component of
period 12 from the series {Xt}, we generate the transformed series

Yt � Xt −Xt−12.

It is clear that all seasonal components of period 12 are eliminated by this transfor-
mation, which is called differencing at lag 12. A linear trend can be eliminated by
differencing at lag 1, and a quadratic trend by differencing twice at lag 1 (i.e., differ-
encing once to get a new series, then differencing the new series to get a second new
series). Higher-order polynomials can be eliminated analogously. It is worth noting
that differencing at lag 12 eliminates not only seasonal components with period 12
but also any linear trend.

Data are differenced in ITSM by selecting Transform>Difference and entering
the required lag in the resulting dialog box.
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Example D.2.8 Restore the original airline passenger data using the option File>Import File and
selecting AIRPASS.TSM. We take natural logarithms as in Example D.2.6 by se-
lecting Transform>Box-Cox and setting λ � 0. The transformed series can now be
deseasonalized by differencing at lag 12. To do this select Transform>Difference,
enter the lag 12 in the dialog box, and click OK. Inspection of the graph of the desea-
sonalized series suggests a further differencing at lag 1 to eliminate the remaining
trend. To do this, repeat the previous step with lag equal to 1 and you will see the
transformed and twice-differenced series shown in Figure D.3.

Subtracting the Mean

The term ARMA model is used in ITSM to denote a zero-mean ARMA process
(see Definition 3.1.1). To fit such a model to data, the sample mean of the data
should therefore be small. Once the apparent deviations from stationarity of the data
have been removed, we therefore (in most cases) subtract the sample mean of the
transformed data from each observation to generate a series to which we then fit a
zero-mean stationary model. Effectively we are estimating the mean of the model by
the sample mean, then fitting a (zero-mean) ARMA model to the “mean-corrected”
transformed data. If we know a priori that the observations are from a process with
zero mean, then this process of mean correction is omitted. ITSM keeps track of all
the transformations (including mean correction) that are made. When it comes time to
predict the original series, ITSM will invert all these transformations automatically.

Example D.2.9 Subtract the mean of the transformed and twice-differenced series AIRPASS.TSM by
selecting Transform>Subtract Mean. To check the current model status press the

Figure D-3
The series AIRPASS.TSM

after taking logs
and differencing
at lags 12 and 1.
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red INFO button, and you will see that the current model is white noise with variance
1, since no model has yet been entered.

D.3 Finding a Model for Your Data

After transforming the data (if necessary) as described above, we are now in a position
to fit an ARMA model. ITSM uses a variety of tools to guide us in the search for
an appropriate model. These include the sample ACF (autocorrelation function),
the sample PACF (partial autocorrelation function), and the AICC statistic, a bias-
corrected form of Akaike’s AIC statistic (see Section 5.5.2).

D.3.1 Autofit

Before discussing the considerations that go into the selection, fitting, and checking
of a stationary time series model, we first briefly describe an automatic feature of
ITSM that searches through ARMA(p, q) models with p and q between specified
limits (less than or equal to 27) and returns the model with smallest AICC value
(see Sections 5.5.2 and D.3.5). Once the data set is judged to be representable by a
stationary model, select Model>Estimation>Autofit. A dialog box will appear in
which you must specify the upper and lower limits for p and q. Since the number of
maximum likelihood models to be fitted is the product of the number of p-values and
the number of q-values, these ranges should not be chosen to be larger than necessary.
Once the limits have been specified, press Start, and the search will begin. You can
watch the progress of the search in the dialog box that continually updates the values
of p and q and the best model found so far. This option does not consider models
in which the coefficients are required to satisfy constraints (other than causality) and
consequently does not always lead to the optimal representation of the data. However,
like the tools described below, it provides valuable information on which to base the
selection of an appropriate model.

D.3.2 The Sample ACF and PACF

Pressing the second yellow button at the top of the ITSM window will produce graphs
of the sample ACF and PACF for values of the lag h from 1 up to 40. For higher lags
chooseStatistics>ACF/PACF>Specify Lag, enter the maximum lag required, and
click OK. Pressing the second yellow button repeatedly then rotates the display through
ACF, PACF, and side-by-side graphs of both. Values of the ACF that decay rapidly as
h increases indicate short-term dependency in the time series, while slowly decaying
values indicate long-term dependency. For ARMA fitting it is desirable to have a
sample ACF that decays fairly rapidly. A sample ACF that is positive and very slowly
decaying suggests that the data may have a trend. A sample ACF with very slowly
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damped periodicity suggests the presence of a periodic seasonal component. In either
of these two cases you may need to transform your data before continuing.

As a rule of thumb, the sample ACF and PACF are good estimates of the ACF
and PACF of a stationary process for lags up to about a third of the sample size. It is
clear from the definition of the sample ACF, ρ̂(h), that it will be a very poor estimator
of ρ(h) for h close to the sample size n.

The horizontal lines on the graphs of the sample ACF and PACF are the bounds
±1.96/

√
n. If the data constitute a large sample from an independent white noise

sequence, approximately 95% of the sample autocorrelations should lie between
these bounds. Large or frequent excursions from the bounds suggest that we need a
model to explain the dependence and sometimes to suggest the kind of model we need
(see below). To obtain numerical values of the sample ACF and PACF, right-click on
the graphs and select Info.

The graphs of the sample ACF and PACF sometimes suggest an appropriate
ARMA model for the data. As a rough guide, if the sample ACF falls between the
plotted bounds ±1.96/

√
n for lags h > q, then an MA(q) model is suggested, while

if the sample PACF falls between the plotted bounds ±1.96/
√
n for lags h > p, then

an AR(p) model is suggested.
If neither the sample ACF nor PACF “cuts off” as in the previous paragraph, a

more refined model selection technique is required (see the discussion of the AICC
statistic in Section 5.5.2). Even if the sample ACF or PACF does cut off at some lag,
it is still advisable to explore models other than those suggested by the sample ACF
and PACF values.

Example D.3.1 Figure D.4 shows the sample ACF of the AIRPASS.TSM series after taking loga-
rithms, differencing at lags 12 and 1, and subtracting the mean. Figure D.5 shows the
corresponding sample PACF. These graphs suggest that we consider an MA model
of order 12 (or perhaps 23) with a large number of zero coefficients, or alternatively
an AR model of order 12.

D.3.3 Entering a Model

A major function of ITSM is to find an ARMA model whose properties reflect to
a high degree those of an observed (and possibly transformed) time series. Any
particular causal ARMA(p, q) model with p ≤ 27 and q ≤ 27 can be entered
directly by choosing Model>Specify, entering the values of p, q, the coefficients,
and the white noise variance, and clicking OK. If there is a data set already open in
ITSM, a quick way of entering a reasonably appropriate model is to use the option
Model>Estimation>Preliminary, which estimates the coefficients and white noise
variance of an ARMA model after you have specified the orders p and q and selected
one of the four preliminary estimation algorithms available. An optimal preliminary
AR model can also be fitted by checking Find AR model with min AICC in the
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Figure D-4
The sample ACF

of the transformed
AIRPASS.TSM series.
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Preliminary Estimation dialog box. If no model is entered or estimated, ITSM
assumes the default ARMA(0,0), or white noise, model

Xt � Zt,

where {Zt} is an uncorrelated sequence of random variables with mean zero and
variance 1.

Figure D-5
The sample PACF
of the transformed

AIRPASS.TSM series.
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If you have data and no particular ARMA model in mind, it is advisable to use
the option Model>Estimation>Preliminary or equivalently to press the blue PRE
button at the top of the ITSM window.

Sometimes you may wish to try a model found in a previous session or a model
suggested by someone else. In that case choose Model>Specify and enter the re-
quired model. You can save both the model and data from any project by selecting
File>Project>Save as and specifying the name for the new file. When the new
file is opened, both the model and the data will be imported. To create a project with
this model and a new data set select File>Import File and enter the name of the
file containing the new data. (This file must contain data only. If it also contains a
model, then the model will be imported with the data and the model previously in
ITSM will be overwritten.)

D.3.4 Preliminary Estimation

The option Model>Estimation>Preliminary contains fast (but not the most effi-
cient) model-fitting algorithms. They are useful for suggesting the most promising
models for the data, but should be followed by maximum likelihood estimation using
Model>Estimation>Max likelihood. The fitted preliminary model is generally
used as an initial approximation with which to start the nonlinear optimization car-
ried out in the course of maximizing the (Gaussian) likelihood.

To fit an ARMA model of specified order, first enter the values ofp and q (see Sec-
tion 2.6.1). For pure AR models q � 0, and the preliminary estimation option offers a
choice between the Burg and Yule–Walker estimates. (The Burg estimates frequently
give higher values of the Gaussian likelihood than the Yule–Walker estimates.) If
q � 0, you can also check the box Find AR model with min AICC to allow the
program to fit AR models of orders 0, 1, . . . , 27 and select the one with smallest AICC
value (Section 5.5.2). For models with q > 0, ITSM provides a choice between two
preliminary estimation methods, one based on the Hannan–Rissanen procedure and
the other on the innovations algorithm. If you choose the innovations option, a default
value of m will be displayed on the screen. This parameter was defined in Section
5.1.3. The standard choice is the default value computed by ITSM. The Hannan–
Rissanen algorithm is recommended when p and q are both greater than 0, since it
tends to give causal models more frequently than the innovations method. The latter
is recommended when p � 0.

Once the required entries in the Preliminary Estimation dialog box have been
completed, click OK, and ITSM will quickly estimate the parameters of the selected
model and display a number of diagnostic statistics. (If p and q are both greater than
0, it is possible that the fitted model may be noncausal, in which case ITSM sets
all the coefficients to .001 to ensure the causality required for subsequent maximum
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likelihood estimation. It will also give you the option of fitting a model of different
order.)

Provided that the fitted model is causal, the estimated parameters are given with
the ratio of each estimate to 1.96 times its standard error. The denominator (1.96
× standard error) is the critical value (at level .05) for the coefficient. Thus, if the
ratio is greater than 1 in absolute value, we may conclude (at level .05) that the
corresponding coefficient is different from zero. On the other hand, a ratio less than
1 in absolute value suggests the possibility that the corresponding coefficient in the
model may be zero. (If the innovations option is chosen, the ratios of estimates to
1.96 × standard error are displayed only when p � q or p � 0.) In the Preliminary
Estimates window you will also see one or more estimates of the white noise variance
(the residual sum of squares divided by the sample size is the estimate retained by
ITSM) and some further diagnostic statistics. These are −2 lnL

(
φ̂, θ̂, σ̂ 2

)
, where L

denotes the Gaussian likelihood (5.2.9), and the AICC statistic

−2 lnL+ 2(p + q + 1)n/(n− p − q − 2)

(see Section 5.5.2).
Our eventual aim is to find a model with as small an AICC value as possible.

Smallness of the AICC value computed in the preliminary estimation phase is in-
dicative of a good model, but should be used only as a rough guide. Final decisions
between models should be based on maximum likelihood estimation, carried out us-
ing the option Model>Estimation>Max likelihood, since for fixed p and q, the
values of φ, θ, and σ 2 that minimize the AICC statistic are the maximum likelihood
estimates, not the preliminary estimates. After completing preliminary estimation,
ITSM stores the estimated model coefficients and white noise variance. The stored
estimate of the white noise variance is the sum of squares of the residuals (or one-step
prediction errors) divided by the number of observations.

A variety of models should be explored using the preliminary estimation algo-
rithms, with a view to finding the most likely candidates for minimizing AICC when
the parameters are reestimated by maximum likelihood.

Example D.3.2 To find the minimum-AICC Burg AR model for the logged, differenced, and mean-
corrected series AIRPASS.TSM currently stored in ITSM, press the blue PRE button,
set the MA order equal to zero, select Burg and Find AR model with min AICC,
and then click OK. The minimum-AICC AR model is of order 12 with an AICC value
of −458.13. To fit a preliminary MA(25) model to the same data, press the blue
PRE button again, but this time set the AR order to 0, the MA order to 25, select
Innovations, and click OK.

The ratios (estimated coefficient)/(1.96×standard error) indicate that the coeffi-
cients at lags 1 and 12 are nonzero, as suggested by the sample ACF. The estimated
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coefficients at lags 3 and 23 also look substantial even though the corresponding
ratios are less than 1 in absolute value. The displayed values are as follows:

MA COEFFICIENTS
−.3568 .0673 −.1629 −.0415 .1268
.0264 .0283 −.0648 .1326 −.0762

−.0066 −.4987 .1789 −.0318 .1476
−.1461 .0440 −.0226 −.0749 −.0456
−.0204 −.0085 .2014 −.0767 −.0789

RATIO OF COEFFICIENTS TO (1.96*STANDARD ERROR)
−2.0833 .3703 −.8941 −.2251 .6875

.1423 .1522 −.3487 .7124 −.4061
−.0353 −2.6529 .8623 −.1522 .7068
−.6944 .2076 −.1065 −.3532 −.2147
−.0960 −.0402 .9475 −.3563 −.3659

The estimated white noise variance is .00115 and the AICC value is −440.93, which
is not as good as that of the AR(12) model. Later we shall find a subset MA(25)
model that has a smaller AICC value than both of these models.

D.3.5 The AICC Statistic

The AICC statistic for the model with parameters p, q,φ, and θ is defined (see
Section 5.2.2) as

AICC(φ,θ) � −2 lnL(φ,θ, S(φ,θ)/n)+ 2(p + q + 1)n/(n− p − q − 2),

and a model chosen according to the AICC criterion minimizes this statistic.
Model-selection statistics other than AICC are also available in ITSM. A Bayesian

modification of the AIC statistic known as the BIC statistic is also computed in the
option Model>Estimation>Max likelihood. It is used in the same way as the
AICC.

An exhaustive search for a model with minimum AICC or BIC value can be
very slow. For this reason the sample ACF and PACF and the preliminary estimation
techniques described above are useful in narrowing down the range of models to
be considered more carefully in the maximum likelihood estimation stage of model
fitting.

D.3.6 Changing Your Model

The model currently stored by the program can be checked at any time by selecting
Model>Specify. Any parameter can be changed in the resulting dialog box, including
the white noise variance. The model can be filed together with the data for later use
by selecting File>Project>Save as and specifying a file name with suffix .TSM.
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Example D.3.3 We shall now set some of the coefficients in the current model to zero. To do this choose
Model>Specify and click on the box containing the value−.35676 of Theta(1). Press
Enter, and the value of Theta(2) will appear in the box. Set this to zero. Press Enter
again, and the value of Theta(3) will appear. Continue to work through the coefficients,
setting all except Theta(1), Theta(3), Theta(12), and Theta(23) equal to zero. When
you have reset the parameters, click OK, and the new model stored in ITSM will be
the subset MA(23) model

Xt � Zt − .357Zt−1 − .163Zt−3 − .499Zt−12 + .201Zt−23,

where {Zt} ∼ WN(0, .00115).

D.3.7 Maximum Likelihood Estimation

Once you have specified values of p and q and possibly set some coefficients to zero,
you can carry out efficient parameter estimation by selecting Model>Estimation>
Max likelihood or equivalently by pressing the blue MLE button.

The resulting dialog box displays the default settings, which in most cases will
not need to be modified. However, if you wish to compute the likelihood without
maximizing it, check the box labeled No optimization. The remaining information
concerns the optimization settings. (With the default settings, any coefficients that
are set to zero will be treated as fixed values and not as parameters. Coefficients to
be optimized must therefore not be set exactly to zero. If you wish to impose further
constraints on the optimization, press the Constrain optimization button. This
allows you to fix certain coefficients or to impose multiplicative relationships on the
coefficients during optimization.)

To find the maximum likelihood estimates of your parameters, click OK, and the
estimated parameters will be displayed. To refine the estimates, repeat the estimation,
specifying a smaller value of the accuracy parameter in the Maximum Likelihood
dialog box.

Example D.3.4. To find the maximum likelihood estimates of the parameters in the model for the
logged, differenced, and mean-corrected airline passenger data currently stored in
ITSM, press the blue MLE button and click OK. The following estimated parameters
and diagnostic statistics will then be displayed:

ARMA MODEL:
X(t) � Z(t)+ (−.355) ∗ Z(t − 1)+ (−.201) ∗ Z(t − 3)+ (−.523) ∗ Z(t − 12)+ (.242) ∗ Z(t − 23)

WN Variance = .001250

MA Coefficients
THETA( 1)= -.355078 THETA( 3)= -.201125
THETA(12)= -.523423 THETA(23)= .241527
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Standard Error of MA Coefficients
THETA( 1): .059385 THETA( 3): .059297
THETA(12): .058011 THETA(23): .055828

(Residual SS)/N = .125024E-02
AICC = -.486037E+03
BIC = -.487622E+03

-2 Ln(Likelihood)= -.496517E+03

Accuracy parameter = .00205000

Number of iterations = 5

Number of function evaluations = 46

Optimization stopped within accuracy level.

The last message indicates that the minimum of −2 lnL has been located with
the specified accuracy. If you see the message

Iteration limit exceeded,
then the minimum of −2 lnL could not be located with the number of iterations (50)
allowed. You can continue the search (starting from the point at which the iterations
were interrupted) by pressing the MLE button to continue the minimization and
possibly increasing the maximum number of iterations from 50 to 100.

D.3.8 Optimization Results

After maximizing the Gaussian likelihood, ITSM displays the model parameters
(coefficients and white noise variance), the values of −2 lnL, AICC, BIC, and infor-
mation regarding the computations.

Example D.3.5 The next stage of the analysis is to consider a variety of competing models and to
select the most suitable. The following table shows the AICC statistics for a variety
of subset moving average models of order less than 24.

Lags AICC

1 3 12 23 −486.04
1 3 12 13 23 −485.78
1 3 5 12 23 −489.95
1 3 12 13 −482.62
1 12 −475.91

The best of these models from the point of view of AICC value is the one with
nonzero coefficients at lags 1, 3, 5, 12, and 23. To obtain this model from the one
currently stored in ITSM, select Model>Specify, change the value of THETA(5)
from zero to .001, and click OK. Then reoptimize by pressing the blue MLE button
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and clicking OK. You should obtain the noninvertible model

Xt � Zt − .434Zt−1 − .305Zt−3 + .238Zt−5 − .656Zt−12 + .351Zt−23,

where {Zt} ∼ WN(0, .00103). For future reference, file the model and data as AIR-
PASS2.TSM using the option File>Project>Save as.

The next step is to check our model for goodness of fit.

D.4 Testing Your Model

Once we have a model, it is important to check whether it is any good or not. Typi-
cally this is judged by comparing observations with corresponding predicted values
obtained from the fitted model. If the fitted model is appropriate then the prediction
errors should behave in a manner that is consistent with the model. The residuals are
the rescaled one-step prediction errors,

Ŵt � (Xt − X̂t )/
√
rt−1,

where X̂t is the best linear mean-square predictor of Xt based on the observations up
to time t − 1, rt−1 � E(Xt − X̂t )

2/σ 2 and σ 2 is the white noise variance of the fitted
model.

If the data were truly generated by the fitted ARMA(p, q)model with white noise
sequence {Zt}, then for large samples the properties of {Ŵt} should reflect those of
{Zt}. To check the appropriateness of the model we therefore examine the residual
series {Ŵt}, and check that it resembles a realization of a white noise sequence.

ITSM provides a number of tests for doing this in the Residuals Menu, which
is obtained by selecting the option Statistics>Residual Analysis. Within this
option are the suboptions

Plot
QQ-Plot (normal)
QQ-Plot (t-distr)
Histogram
ACF/PACF
ACF Abs vals/Squares
Tests of randomness
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D.4.1 Plotting the Residuals

Select Statistics>Residual Analysis>Histogram, and you will see a histogram
of the rescaled residuals, defined as

R̂t � Ŵt/σ̂ ,

where nσ̂ 2 is the sum of the squared residuals. If the fitted model is appropriate, the
histogram of the rescaled residuals should have mean close to zero. If in addition the
data are Gaussian, this will be reflected in the shape of the histogram, which should
then resemble a normal density with mean zero and variance 1.

Select Statistics>Residual Analysis>Plot and you will see a graph of R̂t

vs. t . If the fitted model is appropriate, this should resemble a realization of a white
noise sequence. Look for trends, cycles, and nonconstant variance, any of which
suggest that the fitted model is inappropriate. If substantially more than 5% of the
rescaled residuals lie outside the bounds ±1.96 or if there are rescaled residuals far
outside these bounds, then the fitted model should not be regarded as Gaussian.

Compatibility of the distribution of the residuals with either the normal distribu-
tion or the t-distribution can be checked by inspecting the corresponding qq plots and
checking for approximate linearity. To test for normality, the Jarque-Bera statistic is
also computed.

Example D.4.1 The histogram of the rescaled residuals from our model for the logged, differenced,
and mean-corrected airline passenger series is shown in Figure D.6. The mean is
close to zero, and the shape suggests that the assumption of Gaussian white noise is
not unreasonable in our proposed model.

The graph of R̂t vs. t is shown in Figure D.7. A few of the rescaled residuals
are greater in magnitude than 1.96 (as is to be expected), but there are no obvious
indications here that the model is inappropriate. The approximate linearity of the
normal qq plot and the Jarque-Bera test confirm the approximate normality of the
residuals.

D.4.2 ACF/PACF of the Residuals

If we were to assume that our fitted model is the true process generating the data,
then the observed residuals would be realized values of a white noise sequence.

In particular, the sample ACF and PACF of the observed residuals should lie
within the bounds ±1.96/

√
n roughly 95% of the time. These bounds are displayed

on the graphs of the ACF and PACF. If substantially more than 5% of the correlations
are outside these limits, or if there are a few very large values, then we should look
for a better-fitting model. (More precise bounds, due to Box and Pierce, can be found
in TSTM Section 9.4.)
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Example D.4.2 Choose Statistics>Residual Analysis>ACF/PACF, or equivalently press the
middle green button at the top of the ITSM window. The sample ACF and PACF
of the residuals will then appear as shown in Figures D.8 and D.9. No correlations
are outside the bounds in this case. They appear to be compatible with the hypothesis
that the residuals are in fact observations of a white noise sequence. To check for
independence of the residuals, the sample autocorrelation functions of their absolute
values and squares can be plotted by clicking on the third green button.

Figure D-7
Time plot of the

rescaled residuals
from AIRPASS.MOD.
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Figure D-8
Sample ACF of the residuals
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D.4.3 Testing for Randomness of the Residuals

The option Statistics>Residual Analysis>Tests of Randomness carries out
the six tests for randomness of the residuals described in Section 5.3.3.

Example D.4.3 The residuals from our model for the logged, differenced, and mean-corrected series
AIRPASS.TSM are checked by selecting the option indicated above and selecting

Figure D-9
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the parameter h for the portmanteau tests. Adopting the value h � 25 suggested by
ITSM, we obtain the following results:

RANDOMNESS TEST STATISTICS (see Section 5.3.3)
———————————————————————

LJUNG-BOX PORTM.= 13.76 CHISQUR( 20), p-value = 0.843

MCLEOD-LI PORTM.= 17.39 CHISQUR( 25), p-value = 0.867

TURNING POINTS = 87. ANORMAL( 86.00, 4.79**2), p-value = 0.835

DIFFERENCE-SIGN = 65. ANORMAL( 65.00, 3.32**2), p-value = 1.000

RANK TEST = 3934. ANORMAL(4257.50, 251.3**2), p-value = 0.198

JARQUE-BERA = 4.33 CHISQUR(2) p-value = 0.115

ORDER OF MIN AICC YW MODEL FOR RESIDUALS = 0

Every test is easily passed by our fitted model (with significance level α �
.05), and the order of the minimum-AICC AR model for the residuals supports the
compatibility of the residuals with white noise. For later use, file the residuals by
pressing the red EXP button and exporting the residuals to a file with the name
AIRRES.TSM.

D.5 Prediction

One of the main purposes of time series modeling is the prediction of future ob-
servations. Once you have found a suitable model for your data, you can predict
future values using the option Forecasting>ARMA. (The other options listed under
Forecasting refer to the methods of Chapter 9.)

D.5.1 Forecast Criteria

Given observationsX1, . . . , Xn of a series that we assume to be appropriately modeled
as an ARMA(p, q) process, ITSM predicts future values of the series Xn+h from the
data and the model by computing the linear combination Pn(Xn+h) ofX1, . . . , Xn that
minimizes the mean squared error E(Xn+h − Pn(Xn+h))2.

D.5.2 Forecast Results

Assuming that the current data set has been adequately fitted by the current
ARMA(p, q) model, choose Forecasting>ARMA, and you will see the ARMA Fore-
cast dialog box.
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You will be asked for the number of forecasts required, which of the transforma-
tions you wish to invert (the default settings are to invert all of them so as to obtain
forecasts of the original data), whether or not you wish to plot prediction bounds
(assuming normality), and if so, the confidence level required, e.g., 95%. After pro-
viding this information, click OK, and the data will be plotted with the forecasts (and
possibly prediction bounds) appended. As is to be expected, the separation of the
prediction bounds increases with the lead time h of the forecast.

Right-click on the graph, select Info, and the numerical values of the predictors
and prediction bounds will be printed.

Example D.5.1 We left our logged, differenced, and mean-corrected airline passenger data stored in
ITSM with the subset MA(23) model found in Example D.3.5. To predict the next
24 values of the original series, select Forecasting>ARMA and accept the default
settings in the dialog box by clicking OK. You will then see the graph shown in Figure
D.10. Numerical values of the forecasts are obtained by right-clicking on the graph
and selecting Info. The ARMA Forecast dialog box also permits using a model
constructed from a subset of the data to obtain forecasts and prediction bounds for
the remaining observed values of the series.

D.6 Model Properties

ITSM can be used to analyze the properties of a specified ARMA process without
reference to any data set. This enables us to explore and compare the properties

Figure D-10
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of different ARMA models in order to gain insight into which models might best
represent particular features of a given data set.

For any ARMA(p, q) process or fractionally integrated ARMA(p, q) process
with p ≤ 27 and q ≤ 27, ITSM allows you to compute the autocorrelation and
partial autocorrelation functions, the spectral density and distribution functions, and
the MA(∞) and AR(∞) representations of the process. It also allows you to generate
simulated realizations of the process driven by either Gaussian or non-Gaussian noise.
The use of these options is described in this section.

Example D.6.1 We shall illustrate the use of ITSM for model analysis using the model for the trans-
formed series AIRPASS.TSM that is currently stored in the program.

D.6.1 ARMA Models

For modeling zero-mean stationary time series, ITSM uses the class of ARMA (and
fractionally integrated ARMA) processes. ITSM Enables you to compute character-
istics of the causal ARMA model defined by

Xt � φ1Xt−1 + φ2Xt−2 + · · · + φpXt−p + Zt + θ1Zt−1 + θ2Zt−2 + · · · + θqZt−q,

or more concisely φ(B)Xt � θ(B)Zt , where {Zt} ∼ WN
(
0, σ 2

)
and the parame-

ters are all specified. (Characteristics of the fractionally integrated ARIMA(p, d, q)
process defined by

(1 − B)dφ(B)Xt � θ(B)Zt , |d| < 0.5,

can also be computed.)
ITSM works exclusively with causal models. It will not permit you to enter a

model for which 1−φ1z− · · ·−φpz
p has a zero inside or on the unit circle, nor does

it generate fitted models with this property. From the point of view of second-order
properties, this represents no loss of generality (Section 3.1). If you are trying to
enter an ARMA(p, q) model manually, the simplest way to ensure that your model
is causal is to set all the autoregressive coefficients close to zero (e.g., .001). ITSM
will not accept a noncausal model.

ITSM does not restrict models to be invertible. You can check whether or not
the current model is invertible by choosing Model>Specify and pressing the button
labeled Causal/Invertible in the resulting dialog box. If the model is noninvertible,
i.e., if the moving-average polynomial 1 + θ1z + · · · + θqz

q has a zero inside or on
the unit circle, the message Non-invertible will appear beneath the box contain-
ing the moving-average coefficients. (A noninvertible model can be converted to an
invertible model with the same autocovariance function by choosing Model>Switch
to invertible. If the model is already invertible, the program will tell you.)
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D.6.2 Model ACF, PACF

The model ACF and PACF are plotted using Model>ACF/PACF>Model. If you wish
to change the maximum lag from the default value of 40, select Model>ACF/PACF>
Specify Lag and enter the required maximum lag. (It can be much larger than 40,
e.g., 10000). The graph will then be modified, showing the correlations up to the
specified maximum lag.

If there is a data file open as well as a model in ITSM, the model ACF and PACF
can be compared with the sample ACF and PACF by pressing the third yellow button
at the top of the ITSM window. The model correlations will then be plotted in red,
with the corresponding sample correlations shown in the same graph but plotted in
green.

Example D.6.2 The sample and model ACF and PACF for the current model and transformed series
AIRPASS.TSM are shown in Figures D.11 and D.12. They are obtained by pressing
the third yellow button at the top of the ITSM window. The vertical lines represent the
model values, and the squares are the sample ACF/PACF. The graphs show that the
data and the model ACF both have large values at lag 12, while the sample and model
partial autocorrelation functions both tend to die away geometrically after the peak at
lag 12. The similarities between the graphs indicate that the model is capturing some
of the important features of the data.

Figure D-11
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Figure D-12
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D.6.3 Model Representations

As indicated in Section 3.1, if {Xt} is a causal ARMA process, then it has an MA(∞)
representation

Xt �
∞∑
j�0

ψjZt−j , t � 0,±1,±2, . . . ,

where
∞∑
j�0

|ψj | < ∞ and ψ0 � 1.

Similarly, if {Xt} is an invertible ARMA process, then it has an AR(∞) repre-
sentation

Zt �
∞∑
j�0

πjXt−j , t � 0,±1,±2, . . . ,

where
∑∞

j�0 |πj | < ∞ and π0 � 1.
For any specified causal ARMA model you can determine the coefficients in these

representations by selecting the option Model>AR/MA Infinity. (If the model is not
invertible, you will see only the MA(∞) coefficients, since the AR(∞) representation
does not exist in this case.)

Example D.6.3 The current subset MA(23) model for the transformed series AIRPASS.TSM does
not have an AR(∞) representation, since it is not invertible. However, we can replace



The Bartlett Press, Inc. brockwel 2 · v · 2002 9:02 a.m. Page 420

420 Appendix D An ITSM Tutorial

the model with an invertible one having the same autocovariance function by select-
ing Model>Switch to Invertible. For this model we can then find an AR(∞)
representation by selecting Model>AR Infinity. This gives 50 coefficients, the first
20 of which are shown below.

MA-Infinity AR − Infinity

j psi(j) pi(j)

0 1.00000 1.00000
1 −.36251 .36251
2 .01163 .11978
3 −.26346 .30267
4 −.06924 .27307
5 .15484 −.00272
6 −.02380 .05155
7 −.06557 .16727
8 −.04487 .10285
9 .01921 .01856
10 −.00113 .07947
11 .01882 .07000
12 −.57008 .58144
13 .00617 .41683
14 .00695 .23490
15 .03188 .37200
16 .02778 .38961
17 .01417 .10918
18 .02502 .08776
19 .00958 .22791

D.6.4 Generating Realizations of a Random Series

ITSM can be used to generate realizations of a random time series defined by the
currently stored model.

To generate such a realization, select the option Model>Simulate, and you will
see the ARMA Simulation dialog box. You will be asked to specify the number of
observations required, the white noise variance (if you wish to change it from the cur-
rent value), and an integer-valued random number seed (by specifying and recording
this integer with up to nine digits you can reproduce the same realization at a later
date by reentering the same seed). You will also have the opportunity to add a spec-
ified mean to the simulated ARMA values. If the current model has been fitted to
transformed data, then you can also choose to apply the inverse transformations to the
simulated ARMA to generate a simulated version of the original series. The default
distribution for the white noise is Gaussian. However, by pressing the button Change
noise distribution you can select from a variety of alternative distributions or
by checking the box Use Garch model for noise process you can generate an
ARMA process driven by GARCH noise. Finally, you can choose whether the sim-
ulated data will overwrite the data set in the current project or whether they will be
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used to create a new project. Once you are satisfied with your choices, click OK, and
the simulated series will be generated.

Example D.6.4 To generate a simulated realization of the series AIRPASS.TSM using the current
model and transformed data set, select the option Model>Simulate. The default
options in the dialog box are such as to generate a realization of the original series
as a new project, so it suffices to click OK. You will then see a graph of the simulated
series that should resemble the original series AIRPASS.TSM.

D.6.5 Spectral Properties

Spectral properties of both data and fitted ARMA models can also be computed and
plotted with the aid of ITSM. The spectral density of the model is determined by
selecting the option Spectrum>Model. Estimation of the spectral density from ob-
servations of a stationary series can be carried out in two ways, either by fitting an
ARMA model as already described and computing the spectral density of the fitted
model (Section 4.4) or by computing the periodogram of the data and smoothing (Sec-
tion 4.2). The latter method is applied by selecting the option Spectrum>Smoothed
Periodogram. Examples of both approaches are given in Chapter 4.

D.7 Multivariate Time Series

Observations {x1, . . . , xn} of an m-component time series must be stored as an ASCII
file with n rows and m columns, with at least one space between entries in the same
row. To open a multivariate series for analysis, select File>Project>Open>Multi-
variate and click OK. Then double-click on the file containing the data, and you will
be asked to enter the number of columns (m) in the data file. After doing this, click
OK, and you will see graphs of each component of the series, with the multivariate
tool bar at the top of the ITSM screen. For examples of the application of ITSM to
the analysis of multivariate series, see Chapter 7.
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