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    Chapter 2   

 Computer-Assisted Modeling of Antibody Variable Domains       

      Oscar   H.  P.   Ramos        

  Abstract 

 Antibody modeling is an interesting option to gain structure–function insights and to allow rational 
engineering of these molecules in the absence of experimental data. Among a diversity of algorithms, software 
packages, and specialized Web servers, the protocol described here presents the following main features: 
(1) nonautomatic modeling process guided by direct application of antibody modeling principles; (2) local 
generation of molecular models using free software which can be used in most common operational systems; 
and (3) the resulting model quality is comparable to models generated by Web servers which represent the 
current standard of antibody modeling. Brie fl y, hybrid models of heavy- and light-chain variable domains 
are separately built by grafting segments from homologous templates (framework regions and complemen-
tarity-determining regions). Next, hybrid models are mutated to comply with the target’s sequence and 
associated by  fi tting into a template structure that closely matches the predicted packing angle for the 
target variable domains. After a few cycles of energy minimization the model can be submitted to CDR-H3 
optimization or its quality can be directly assessed.  

  Key words:   Antibody ,  Variable domains ,  Modeling ,  Antigen combining site ,  Structure prediction  

  Abbreviations  

  VD    Variable domain   
  FR    Framework region   
  CDR    Complementarity-determining region   
  HV    Antibody heavy-chain variable domain   
  LV    Antibody light-chain variable domain       

 

 The increasing relevance of antibodies in biotechnology and 
therapeutics experienced in the last decades correlates with progress 
in recombinant protein expression, increasing amount of sequence/
structure data, and rising of bioinformatics. Since it is recognized 

  1.  Introduction



40 Oscar H.P. Ramos

that structure is intrinsically related to molecular properties and 
function, at the crossroad of these scienti fi c advances emerges 
antibody engineering, which encompasses methods to predict 
conformations of antibody variable domains (VDs) that are prone 
to happen in life-compatible environments. Concerning predictive 
approaches, two main streams are available: comparative homology 
modeling (see Note 1) and  ab initio  (see Note 2) predictions. 
Regarding antibody variable domains, homology modeling is still 
considered the method of choice since most of the sequence is 
highly conserved and hundreds of high-resolution structure are 
available (see Note 3). The conserved sequence mainly corresponds 
to the framework regions (FRs, Fig.  1 ).  

 Furthermore, analysis of antibody sequence and structure has 
provided “canonical rules” that frequently allow to transpose 
sequence information of  fi ve hypervariable complementarity-
determining regions (CDR-L1, L2, CDR-L3, CDR-H1, and 
CDR-H2) into structural information based on key residues pres-
ent on CDR itself and on framework regions. In opposition to the 
cited hypervariable loops, nature has reserved signi fi cantly higher 
diversity for the last one, CDR-H3, making it more dif fi cult to 
establish canonical rules and constituting an important obstacle 
for generating more reliable models of antibody variable domains 
(see Note 4). Ironically, CDR-H3 is located at the center of anti-
gen binding site and its conformation is generally crucial for anti-
gen recognition. Thus, high-resolution modeling of CDR-H3 is 
very desirable in order to allow good predictions of complex for-
mation with antigens. 

 Some state-of-the-art algorithms implemented in antibody 
modeling servers have demonstrated their values, such as WAM  (  1  )  
(  http://antibody.bath.ac.uk/    , see Note 5), RosettaAntibody  (  2  )  
(  http://antibody.graylab.jhu.edu/    , see Note 6), and PIGS  (  3  )  
(  http://arianna.bio.uniroma1.it/pigs/    , see Note 7). Their interest 
lies on the fact that they require almost no prior modeling knowledge 
and they generally provide good results at the end (see Note 8), so 

  Fig. 1.    Schematic representation of heavy-chain variable domain (VH) and light-chain variable domain (VL). Segments 
corresponding to conserved framework regions (FRs,  white background  ) and hypervariable complementarity-determining 
regions (CDRs,  black background ).  L  indicates antibody light chain;  H  indicates antibody heavy chain.  Numbers  indicate 
consecutive positions of hypervariable loops in the antibody sequence from N- to C-terminus of variable domains.       

 

http://antibody.bath.ac.uk/
http://antibody.graylab.jhu.edu/
http://arianna.bio.uniroma1.it/pigs/
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they are frequently considered as  fi rst choice and the reader is 
encouraged to try them. Nevertheless, some particular sequences 
fail to be automatically processed or, sometimes, it takes more than 
one week for job completion (see Note 9). In these cases, when the 
researcher looks for more detailed control of the modeling process 
(see Note 10) or simply wants to do it locally, other options are 
available including a considerable amount of commercial and non-
commercial software (see Note 11). 

 The modeling protocol described here is intended for local 
generation of models with quality that is comparable to automa-
tized servers (see Note 12). It stands out among a great diversity 
of available approaches because of its direct application of antibody 
modeling concepts and its broad applicability (see Note 13). By 
attempting to compile detailed step-by-step instructions, it is 
expected to be applicable even by researchers with low modeling 
or bioinformatics knowledge. Brie fl y, structural relevant elements 
are identi fi ed from sequences analysis of variable domains, namely, 
FRs and CDRs (Fig.  1 ). Conformation templates are searched and 
selected for structure elements based on sequence similarity and 
resolution. For CDR elements, the length and the respect of 
canonical rules also constitute criteria of primary relevance and 
should be considered. Afterwards, using the selected templates, 
chimeric domains are independently constructed for VL and VH 
which are then mutated to comply the target’s sequence. Finally, 
VH and VL primary models are packaged and the resulting struc-
ture is submitted to a few steps of energy minimization. The pri-
mary model can be submitted to further re fi nements, such as 
simulated annealing of the CDR-H3, or its quality can be directly 
veri fi ed (Fig.  2 ). The required software are free and can run on 
Linux, Mac, or Windows (see Note 14).   

 

    Antibody VH and VL sequences to be modeled.  
  Computer connected to the Internet.  
  Swiss-PdbViewer (SPDBV)—Deep Viewer application.     

 

      1.    Create an organized directory structure intended for the mod-
eling process inside a new directory named after the antibody 
to be modeled ( see   Note 15 ).      

  2.  Materials

  3.  Methods

  3.1.  Creating 
an Organized 
Structure 
of Directories 
for Antibody Modeling
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  Fig. 2.    Flowchart illustrating the antibody modeling protocol described here.       
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  Numbering schemes provide useful standardization of residues’ 
position among homologous sequences, making analysis and com-
parison readily accessible. In past years, several VD numbering 
schemes were proposed, such as Kabat  (  4  )  (based exclusively on 
antibody sequences), Chothia  (  5,   6  )  (based on antibody three-
dimensional structures), a modi fi ed Chothia scheme (aiming to 
correct insertion sites in framework regions)  (  7  ) , and AHo  (  8  )  
(based on three-dimensional structure of antibodies and non-anti-
bodies immunoglobulin VDs). Considering the speci fi c objective 
of modeling antibody VDs, the Chothia scheme is particularly con-
venient ( see   Note 16 ).

    1.    Number VH and VL sequences by Chothia scheme using 
Abnum server  (  7  )  available at   http://www.bioinf.org.uk/abs/
abnum/     and save VH and VL numbered sequences in the 
“Info” directory for future reference.  

    2.    Analyze numbered sequences in order to identify four FRs and 
three CDRs for each chain. Annotate corresponding segments 
( see   Note 17 ) using CDR de fi nitions presented in Table  1 .       

      1.    Search for homologous FR and CDR ( see   Note 18 ) sequences 
using protein BLAST  (  9  )  (  http://blast.ncbi.nlm.nih.gov/
Blast.cgi    ) against Protein Data Bank (pdb) database.      

      1.    Select a template for each segment ( see   Note 19 ). Concerning 
CDR segments, it is preferable to select templates that belong 
to the same canonical class ( see     Tables  2  and  3 : Potential resi-
dues related to canonical CDR conformations).    

    2.    Open SPDBV ( see   Note 20 ) and import PDB  fi le ( see   Notes 
21 ,  22 ,  23 ) corresponding to each selected template.
    Import PDB  fi le: “File” =>“Import …”, enter PDB code, and 
click on PDB  fi le.      

  3.2.  Sequence Analysis 
of Antibody VDs

  3.3.  Homology Search

  3.4.  VH and VL Primary 
Model Building Using 
SPDBV  (  10  ) 

   Table 1 
  CDR de fi nitions in Chothia numbering 
scheme   

 CDR  Residues a  

 L1  L24…L34 

 L2  L50…L56 

 L3  L89…L97 

 H1  H26…H32 

 H2  H52…56 

 H3  H95…102 

   a Residue positions correspond to Chothia number-
ing scheme  

http://www.bioinf.org.uk/abs/abnum/
http://www.bioinf.org.uk/abs/abnum/
http://blast.ncbi.nlm.nih.gov/Blast.cgi
http://blast.ncbi.nlm.nih.gov/Blast.cgi
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   Table 3 
  HV canonical classes of CDR conformations based on potentially related key 
residues   

 H1 
 Class A   1  2  3 
 Class B   10A/B/C/D  11A  12A 
 Length  10  11  12 
 H24  A 6 V 6 T 6 G 6 S 4   V 6 (F 6 )  V 6 F 6 (G 6 ) 
 H26  G 1   (G 6 )  G 6  
 H27 &   Y 1 F 1 G 6 T 4   Y 6 F 6 G 6  
 H29  I 6 F 1 L 3 (V 6 )S 2   I 6 (L 6 )  I 6 L 6 (V 6 ) 
 H34  I 3 V 3 M 1 W 6 (T 6 L 6 )  W 6 (C 6 )  W 6 V 6  
 H94  R 1 K 1 G 3 S 4 

H 4 N 4 (T 6 A 6 ) 
 (H 6 R 6 )  (H 6 R 6 ) 

 H2 
 Class A   1  2  3  4 
 Class B   9A  10A/C/D  10B  12A  10C  10F  12B 
 Length  9  10  10  12  10  10  12 
 H52a &   P 3 T 3 A 6   D 3 P 3 S 3   N 3  
 H54  N 2 S 2 T 2 K 2 D 2 G 2   S 3 G 1 (N 1 D 1 )  (K 3 S 6 N 3 )  N 2 G 2   Y 2  
 H55  G 1 (D 1 )  (G 6 S 3 T 3 )  (G 3 S 3 )  (Y 3 ) 
 H71  R 6 K 6 V 6 (I 6 )  V 2 A 3 L 3 (T 6 )  R 3   R 3   A 2 R 2   V 2  

   A  Chothia and cols class name 
  B  Martin and Thornton class name 
  1  Chothia and Lesk, 1987  (  5  )  
  2  Martin and Thornton, 1996  (  29  )  
  3  Chothia et al. 1989  (  30  )  
  4  Barré et al. 1994  (  31  )  
  6  Chothia et al. 1992  (  33  )  
  &  Nonrelevant position according to Martin and Thornton, 1996 
 (X) not relevant residue based on Martin and Thornton analyses 
 Classes that could not be distinguished based on allowed residues for Chothia proposed key positions were 
assembled into a unique class (CDR-H1 10A/B/C/D, CDR-H2 10A/C/D)  

    3.    Select template residues matching target sequence segment, 
invert selection, and remove non-matching residues.
    Select template residues: “Edit” =>“Find sequence …”, copy tem-
plate sequence matching to the target segment, and paste into the 
sequence  fi eld. Click OK. For noncontinuous selections, such as 
framework regions, “Wind =>Control panel” can be used.   
   Invert selection: “Select” =>“Inverse Selection”.   
   Remove residues: “Build” = > “Remove Selected Residues …”.      

    4.    Use CDR anchor residues to  fi t these segments into FR tem-
plate using backbone atoms. After  fi tting all CDRs into FR 
segments, create a merged layer comprising FRs and CDRs 
without anchor residues. Save the merged layer.
    Select anchor residues and  fi t atoms: Select anchor and corre-
sponding FR residues using “Control panel”. Then  fi t segments 
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using backbone atoms: menu “Fit” =>“Fit Molecules (from selection)”. 
Choose FR layer as reference and CDR layer as mobile.   
   Create a merged layer: Select all residues in the FR template layer 
and CDR residues (do not include anchor residues) and “Edit” 
=>“Create Merged Layer from Selection (by layer)”.     
  Save the merged layer. 
    Save merged layer: Be sure that created merged layer (_merge_) 
is the active layer (its name should appear in the top of the control 
panel). Save merged layer: “File” =>“Save” = > “Current Layer 
…” and choose destination  fi le name and directory.      

    5.    Close all layers.
    Close all layer: “File” =>“Close All Layers”.      

    6.    Using a text editor of your choice, modify the saved  fi le to put 
atoms corresponding to CDR residues in their correct sequence 
order ( see   Note 24 ).  

    7.    Open the modi fi ed PDB  fi le, select all residues, and renumber 
residues.

    Open PDB  fi le: “File” =>“Open PDB File …”, and select location 
and PDB  fi le to be loaded.   
   Select all residues: “Select” =>“All”.   
   Renumber residues: “Edit” =>“Rename Current Layer …”. In 
the  fi eld “Rename Chain of Selected Groups” type H or L (depend-
ing on which VD to be modeled, VH or VL, respectively). In the 
“Renumber Selected Groups from” type 1.      

    8.    Load VH or VL sequence into the workspace and check if the 
merged template and the loaded sequence are correctly 
aligned.

    Load VH or VL sequence: “SwissModel” =>“Load Raw Sequence 
from Amino Acids …” and select a  fi le containing VH or VL 
sequence in FASTA format.   
   Inspect and modify the alignment: “Wind” =>“Alignment”. If 
necessary, the alignment can be edited by selecting the residues to 
be displaced and using “Ctrl” + “Space” keys to move it to the right 
(N- to C-terminus) or “Ctrl” + “Backspace” keys to move it to the 
left (C- to N-terminus).      

    9.    Set the merged template as modeling reference, create a pri-
mary model for the loaded VH or VL sequence (VH-PM or 
VL-PM) by mutation of the merged/hybrid template, and 
save the primary model.
    Set merged template as modeling reference: Make sure that the 
merged template layer is the active layer by selecting its name in 
the drop-down list available at the top of “Control panel”. Execute 
the following menu commands “SwissModel” =>“Set Current 
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Layer as Modelling Reference”, then “Wind” =>“Layers info”, 
and click over the cell corresponding to the intersection of the 
merged template line and the “mdl” column (now, a “v” letter 
should be exhibited)     .   
   Create primary model: “SwissModel” =>“Build Preliminary 
Model for Selected Layers …”.   
   Save the model: Be sure that the created model is the active layer 
(the name imported from the fasta sequence  fi le should appear in 
the top of the control panel) and execute “File” =>“Save” 
=>“Current Layer …” and choose destination  fi le name and 
directory.          

      1.    Using PAPS server  fi nd the template that most closely matches 
the predicted packing angle for the association of target VH 
and VL  (  11  )  and download the proposed PDB  fi le.
    Find suitable template: Access “    www.bioinf.org.uk/abs/paps/     ” 
 and enter the sequences for VH and VL  ( see   Note 25 ).  

       2.    Load the downloaded template, VH-PM and VL-PM struc-
tures into SPDBV workspace ( see  “Open PDB  fi le” section of 
Subheading  3.4 ,  step 7 ).  

    3.    Select template residues H36–H39 and H89–H92 and the 
corresponding residues in VH-PM ( see   Notes 26  and  27 ). Fit 
selected residues using backbone atoms.
    Fit residues: “Fit” =>“Fit Molecules (from selection)”. Use back-
bone atoms only. Assume template layer as reference structure 
( fi xed) and VH-PM layer as mobile structure.   

       4.    Apply the same procedure to VL using template residues L35–
L38 and L85–L88.  

    5.    Dismiss the template structure, select all variable domain residues, 
and create a merged layer comprising VH and VL.
    Dismiss the template structure: Select the template as an active 
layer  ( see   Note 23 )  and execute “File” =>“Close”.   
   Select all residues: Select VH-PM or VL-PM as active layer  ( see  
 Note 23 )  and select all residues.   
   Create a merged layer: “Edit” =>“Create a Merged Layer from 
Selection (by layer)”.      

    6.    Set the energy minimization parameters, perform energy mini-
mization, and save merged layer ( see  “Save merged layer” sec-
tion of Subheading  3.4 ,  step 4 ).
    Set energy minimization parameters: “Prefs” =>“Energy 
Minimization …”. For guiding purposes 50 steps of Steepest 
Descent are recommended but best values are model dependent.   

  3.5.  VH and VL 
Association Using 
Predicted Packing 
Angle

http://www.bioinf.org.uk/abs/paps/
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   Perform energy minimization: “Tools” =>“Energy Minimization 
…” and wait for the job to  fi nish. SwissPDBViewer energy mini-
mization computations are done in vacuum and use an imple-
mentation of GROMOS96 force  fi eld.          

  In opposition to the other CDRs ( see   Note 28 ), long CDR-H3 
loops frequently adopt better conformations after optimization. 
Several methods can be useful for CDR-H3 optimization includ-
ing cyclic coordinate descent (ccd)  (  12  )  and kinematic closure (kic) 
 (  13  )  loop redesign implemented in ROSETTA  (  14  ) ; vacuum, 
implicit, or explicit solvent molecular dynamics (MD) implemented 
in packages such as GROMACS  (  15  ) , NAMD  (  16  ) , and CHARMM 
 (  17  ) ; CAMAL algorithm  (  18  )  that uses CONGEN program  (  19  ) ; 
and loop modeling implemented in MODELLER  (  20  )  (server: 
  http://modbase.compbio.ucsf.edu/modloop/    ). It is a hard task 
to predict which method will provide better results for each case. 
 Next, the application of a simulated annealing MD ( see   Note 29 ) 
protocol implemented using a Linux shell script ( see   Note 30 ) and 
GROMACS ( see   Note 31 ) will be presented. In the mentioned 
protocol only CDR-H3 coordinates are updated during simulation 
while the remaining residues are kept frozen.

    1.    Download the Linux shell script  fi le to the “ path /VDs/
H3-SA” directory (path: directory path preceding VDs direc-
tory) and copy the structure  fi le from the Subheading  3.5 ,  step 
6 , to the same directory.  

    2.    Edit the script if necessary ( see   Note 32 ).  
    3.    In a system terminal, enter the “ path /VDs/H3-SA” directory 

and run the script by typing “./EM-SA” ( see   Note 33 ). Wait 
the job to  fi nish and verify the resulting PDB structure in the 
“SimAnneal” directory. Check for problematic regions and 
visually inspect the resulting model ( see  Subheadings  3.7  and 
 3.8 ) ( see   Note 34 ).      

  The normality of protein stereochemistry and atomic environ-
ments can be assessed by uploading the PDB  fi le to the SAVES 
server (  http://nihserver.mbi.ucla.edu/SAVES/    ), which allows 
concomitant analyses by PROCHECK  (  21  )  and WHAT IF  (  22  )  
packages, among others ( see   Note 35 ). It should be noted that 
template-derived problematic regions are a common source of 
problems regarding homology-based models. Other problems can 
be frequently corrected by side-chain rotamer search ( see   Note 36 ) 
and/or local energy minimization involving problematic residues.  

  Three-dimensional structure visualization and analysis can be 
carried out using software such as Pymol  (  23  ) , VMD  (  24  ) , and 
SPDBV  (  10  ) .  

  3.6.  CDR-H3 
Re fi nement

  3.7.  Veri fi cation 
of Potentially 
Problematic 
Conformations

  3.8.  Model 
Visualization

http://modbase.compbio.ucsf.edu/modloop/
http://nihserver.mbi.ucla.edu/SAVES/


50 Oscar H.P. Ramos

  VH and VL sequences of three randomly selected antibody struc-
tures available at PDB were  de novo  modeled using the protocol 
described here, WAM, RosettaAntibody, or PIGS Web server. 
According to RMSD-to-native criteria, the results presented in 
Table  4  suggest that the models generated by the present approach 
are expected to be comparable to those generated by current algo-
rithms that are implemented in antibody modeling servers (Fig.  3 ).     

  3.9.  Quality 
Perspective of the 
Resulting Models: 
RMSD-to-Native Test

   Table 4 
  Comparison of RMSD-to-native backbone atom distances of models generated 
by WAM, RosettaAntibody, and PIGS antibody modeling servers and the protocol 
described here   

 PDB code  WAM a  
 Rosetta
Antibody  PIGS 

 SPDBV + EM 
+ H3SA  SPDBV + EM  SPDBV 

 3NTC  1.063  1.434  1.084  1.004  1.065  1.075 

 1UYW  0.816  0.262 b   0.869  1.104  1.100  1.105 

 1LMK  1.089  1.477  1.766  1.450  1.624  1.634 

  Backbone RMSD values of equivalent regions comprising packed VH/VL are presented for three random 
test cases. WAM—Web Antibody Modeling Server (  http://antibody.bath.ac.uk/    ); RosettaAntibody server 
(  http://antibody.graylab.jhu.edu/    ; only the model with best energy was considered); PIGS—Prediction 
of Immunoglobulin Structure Server (  http://arianna.bio.uniroma1.it/pigs/    ) 
  SPDBV  model that was not submitted to energy minimization,  SPDBV + EM  energy minimized model, 
 SPDBV + EM + H3SA  Energy minimized model after CDR-H3 optimization by simulated annealing using 
GROMACS 
  a WAM server does not indicate templates used during modeling process; thus the selection of the crystal 
structures of the target sequences as template could not be ruled out 
  b PDB 1UYW was automatically selected by RosettaAntibody server as template for the modeling of all FRs 
and CDRs of HV and LV, compromising in this case the relevance of the RMSD value for the modeling 
of sequences without solved structures. No option was available to reject 1UYW as template  

  Fig. 3.    Superposition of models to the crystallographic structure of KD-247 Fab (PDB 3NTC, solved at 1.55 Å resolution). 
Structures were superposed using backbone atoms (Ca, N, O, C) of anchor residues and CDRs are shown. 3NTC ( red ), WAM 
(blue), RosettaAntibody (green), PIGS ( yellow) and protocol here described (salmon).       

 

http://antibody.bath.ac.uk/
http://antibody.graylab.jhu.edu/
http://arianna.bio.uniroma1.it/pigs/
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     1.    The reasoning behind comparative modeling is that similar 
sequences tend to adopt similar structural conformations under 
similar conditions. It includes homology modeling and protein 
threading.  

    2.     Ab initio  predictions do not use structural data of related 
molecules for model calculation.  

    3.    Thousands of structures are available if lower resolution (above 
2 angstrons) and redundancies are considered.    For updated 
information the reader is invited to visit pdb Internet site: 
  www.pdb.org    .  

    4.    Even if canonical rules for long CDR-H3 loops are not avail-
able, several works propose that their base can be predicted by 
the nature of residues at key positions  (  25–  27  ) .  

    5.    Usually, more than one week is necessary to download the 
resulting model. User intervention is necessary (two residues 
following CDR-L1, CDR-L3, CDR-H1, and CDR-H3 have 
to be provided when opting for the autoalign method; otherwise 
users have to manually align its sequences with some tem-
plates). In order to obtain the required password to download 
each model it is necessary to  fi ll a form and send it back to 
University of Bath (UK). Payment is required for commercial 
users. Templates are automatically selected.  

    6.    Usually, more than one week is necessary to download the 
resulting model (it depends on the amount of pending jobs). 
Low user intervention (selection of parameters). Templates are 
automatically selected.  

    7.    Models are readily generated. Allow the modeling of multiple 
sequences. Low user intervention (selection of parameters). 
Template selection is available.  

    8.    Recent results comparing WAM and RosettaAntibody indicate 
that WAM’s  fi nal models tend to  fi t better experimentally 
solved structures than the best RosettaAntibody models. On 
the other hand, RosettaAntibody usually has a model that is 
closer to the solved structure among its best ten models and 
docking with the ensemble of structures tends to give better 
complexes with antigen than WAM’s best model  (  28  ) .  

    9.    It is often the case for WAN and RosettaAntibody servers, but 
not for PIGS server.  

    10.    Such as analyses of the effect of different templates on the  fi nal 
model, optimization of modeling parameters, and test of dif-
ferent re fi nement strategies.  

    11.    For instance, Modeller, Discovery Studio, Rosetta, Tinker, 
Yasara, and SwissPDB-Viewer.  

  4.  Notes

http://www.pdb.org
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    12.    Comparisons of models generated by the method delineated 
here and Modeller or Rosetta package (please note that recent 
versions of Rosetta package do not include the implementation 
of the speci fi c algorithm used by RosettaAntibody server) using 
standard parameters indicate that, in the particular case of anti-
body modeling, the former tends to yield results that are closer 
to experimentally solved structures and comparable to WAM, 
RosettaAntibody, and PIGS servers.  

    13.    The method described here is broadly applicable regarding the 
required computational resources (hardware and software) and 
the associated    cost. It is also widely applicable in the sense that 
a wide diversity of antibody VDs can be predicted.  

    14.    For the better understanding of each step, the  fi les correspond-
ing to the modeling process of the three test cases described 
here can be downloaded at   https: //docs.google.com/
open?id=0B_zucHwbv9VAblpIeVhkZWFvNDA    .  

    15.    Ready-to-use directory structure is available at   https: //docs.
google.com/open?id=0B_zucHwbv9VAWW42VmRfb2pEaG8    .  

    16.    Optionally, Chothia modi fi ed-scheme is also suitable to be 
applied.  

    17.    Annotation of HV and LV segments is a good modeling prac-
tice that facilitates nonautomatic modeling processes and pre-
vents modeling errors due to mistaken assignments of variable 
domain segments. A template  fi le for comprehensive annota-
tion of HV and LV segments is available at   https: //docs.google.
com/open?id=0B_zucHwbv9VAOU1tb0R4WlI4LXM    .  

    18.    To search for homologous template of CDRs use the CDR 
sequence itself plus two anchor residues at N-terminus and 
two anchor residues at C-terminus (2res + CDR + 2res). 
Eventually, H3 loops of appropriate size are dif fi cult to  fi nd 
using standard BLAST parameters. In these cases, PHI-BLAST 
can be used to exclude hits that do not match loop size ( see : 
  http://www.ncbi.nlm.nih.gov/blast/html/PHIsyntax.html     
for syntax of PHI-BLAST patterns). Similarly, keywords that 
would limit the search to antibody-related molecules can be 
entered in the “Entrez Query”  fi eld (i.e., antibody, immuno-
globulin, Fab, scfv, minibody, etc.).  

    19.    For template selection consider the respect of known canonical 
rules, sequence similarity, and experimental resolution of the 
structure. Dr. Andrew C.R. Martin’s Group developed a sys-
tem for automatic assignment of canonical classes to CDRs 
(Web server available at   http://www.bioinf.org.uk/abs/
chothia.html    ).  

    20.    Swiss-PDBViewer—Deep View software (SPDBV)—can run 
on Windows, Mac, and Linux. Download page:   http://spdbv.
vital-it.ch/disclaim.html    .  

https://docs.google.com/open?id=0B_zucHwbv9VAblpIeVhkZWFvNDA
https://docs.google.com/open?id=0B_zucHwbv9VAblpIeVhkZWFvNDA
https://docs.google.com/open?id=0B_zucHwbv9VAWW42VmRfb2pEaG8
https://docs.google.com/open?id=0B_zucHwbv9VAWW42VmRfb2pEaG8
https://docs.google.com/open?id=0B_zucHwbv9VAOU1tb0R4WlI4LXM
https://docs.google.com/open?id=0B_zucHwbv9VAOU1tb0R4WlI4LXM
http://www.ncbi.nlm.nih.gov/blast/html/PHIsyntax.html
http://www.bioinf.org.uk/abs/chothia.html
http://www.bioinf.org.uk/abs/chothia.html
http://spdbv.vital-it.ch/disclaim.html
http://spdbv.vital-it.ch/disclaim.html
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    21.    PDB  fi le documentation available at   http://www.wwpdb.org/
docs.html    .  

    22.    Sequentially opening FRs, CDR-1, CDR-2, and CDR-3 tem-
plate structures can facilitate the work making it more 
organized.  

    23.    A given structure can be de fi ned as active layer by selecting its 
corresponding code in the top of “Control panel.”  

    24.    Atoms descriptions lines (beginning with ATOM) from different 
templates should be subsequently listed in the merged  fi le. Cut 
and paste atoms descriptions from different templates to the 
correct sequence order (i.e., FR-1 atoms followed by CDR-1, 
FR-2, CDR-2, FR-3, CDR-3, and FR-4 atoms).  

    25.    Generally, the use of template structures derived from the pre-
dicted VH/VL packing angle allows the generation of  fi nal 
models that are slightly closer to the expected structure than 
models derived from templates selected based on framework 
regions    homology.  

    26.    Aiming to facilitate the selection of matching residues, tem-
plate and primary model sequences can be manually aligned 
using Alignment Window ( see  “Inspect and modify the align-
ment” section of Subheading  3.4 ,  step 8 ).  

    27.    Exactly the same number of matching residues should be 
selected in each structure.  

    28.    Re fi nement of structures derived from canonical templates 
generally results in worse conformation.  

    29.    In brief, Simulated Annealing implies simulation of the effect 
of heat on molecular dynamics which allows bad conforma-
tions to surmount energy barriers corresponding to local-
minimum conformations followed by a gradual decrease in the 
system temperature expecting to achieve a new conformation 
that is more energetically favorable.  

    30.    Even if the shell script was designed for Linux, it can be adapted 
for other systems or can be used to guide command-line 
procedures. Sample script available at   https: //docs.google.
com/open?id=0B_zucHwbv9VAemx1VDdxNWdxSTQ    .  

    31.    GROMACS packages are available for most popular Linux 
distributions and Mac OS. Binaries are also available for 
Windows. Optionally, platform-speci fi c binaries can be built 
from the source code.  

    32.    At least the target  fi le name should be veri fi ed (next to “setenv 
MOL” statement). It is recommended to number consecutively 
VD residues on the packaged VDs model (over both chains,  see  
section “Renumber residues” of Subheading  3.4 ,  step 7 ), so the 
residue range upstream and downstream the CDR-H3 can be 
easily de fi ned as frozen while loop residues will be de fi ned as 

http://www.wwpdb.org/docs.html
http://www.wwpdb.org/docs.html
https://docs.google.com/open?id=0B_zucHwbv9VAemx1VDdxNWdxSTQ
https://docs.google.com/open?id=0B_zucHwbv9VAemx1VDdxNWdxSTQ
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mobile during simulated annealing. Change residues range if 
necessary in the index  fi le section of the script.  

    33.    To be run as Linux shell script, the  fi le must have execution 
permission. To allow the  fi le to be executed use chmod + x “ fi le 
name” (e.g., “chmod + x EM + SA”).  

    34.    GROMACS package provides several programs allowing to 
analyze the atomic trajectories during simulation. Atomic tra-
jectories can be visualized using VMD (  http://www.ks.uiuc.
edu/Research/vmd/    ).  

    35.    Optionally, PROCHECK can be downloaded at   http://www.
ebi.ac.uk/thornton-srv/software/PROCHECK/download.
html     and WHAT_CHECK at   http://swift.cmbi.ru.nl/gv/
whatcheck/whatcheck_8.3_beta.tar.bz2    .  

    36.    SPDBV offers rotamer search in conjunction with its mutation 
tool (  http://spdbv.vital-it.ch/mutation_guide.html    ).          
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