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Steps for Downloading and/or Installing Java SE 7,  

the JMF, Apache Tomcat  & Eclipse 
 

Java SE 7 

The download instructions below refer to the latest version of the Java Standard Edition (Java SE), 

which (at the time of writing) is Java SE 7 Update 5. The Java SE Development Kit (JDK) includes the 

Java Runtime Environment (JRE) and command-line development tools. It is actually the JDK that you 

are downloading, but we shall be referring only to the Java SE. 

 

1. Go to http://www.oracle.com/technetwork/java/javase/downloads/index.html. 

 

2. Click on the Download button underneath JDK, which is to the right of the text heading showing 

the latest version of Java.  

 

3. In the table heading halfway down the page, click on the radio button to accept the licence 

agreement. 

 

4. Click on the filename that appears alongside Windows x86. (This should have the format jdk-

7u<Update version>-windows-i586.exe, where <Update version> is replaced with a number that is 

either 5 or one slightly higher. 

 

5. Click on the Save button and navigate to a suitable location for the download file (probably the top 

level of your drive C) and then click the next Save button. (File takes up 87.95MB or more.) 

 

6. After downloading to a suitable location, click on the Open Folder button. 

 

7. Double-click on the executable file that has either been downloaded or been copied from the CD.  

 

8. Click on the Run button. 

 

9. Click on the Next> button (when it becomes available). 

 

10. Customisation is now allowed, via selection from 3 component groups, but simply leave the default 

selection of Development Tools. (Requires 300MB of disc space.) 

If you wish to change the default (JDK) installation directory to something more distinctive (such 

as C:\JavaSE7), then use the Change... button, navigate to your desired location, create a new 

folder if you wish (e.g., JavaSE7) and click on OK. 

 

11. In the next window, click on Next>. 

  

12. Click on the Change… button if you wish to change the default JRE installation folder (probably to 

JavaSE7\jre), navigate to the desired folder, select it and then click on OK. [Should NOT really be 

necessary, since you will merely be overwriting contents of existing jre folder, but can't 

abandon this without abandoning whole download!] 
 

13. Click on Next>. 

 

14. At the end of the installation process, click on Continue. 

 

15. You may need to go through a process similar to the above for downloading the SDK, clicking on 

Close at the end. 

 

16. Register with Oracle, if you wish, but there is no need for this. 
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17. Modify your system's Path environment variable so that it references the bin folder of the above 

installation. This is very important! In case you are unsure how to modify the Path variable, the 

steps are given below, for Windows 7.  

 From the Start menu at the bottom left of the screen, select:  

   Control panel -> System and Security 

     -> System 

     -> Advanced system settings (in pane on left) 

     ->Advanced (Tab)    

     ->Environment variables… (Button).  

 Scroll to the Path system variable and select the current contents of this variable by clicking on 

them.  

 Click on the Edit… button, press the keyboard Home button (ensuring that NumLock is not on) 

and insert the full path to Java's bin folder at the start of the current contents (probably 

C:\JavaSE7\bin, if you have followed the earlier suggestions for folder names). Make sure that 

you remember to place a semi-colon at the end of this new entry, in order to separate it 

from the next item. 

 Click OK three times to finish off. 
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Tomcat 7 (Implements the Servlet 3.0 and JSP 2.2 specifications.) 

1. Go to http://tomcat.apache.org/whichversion.html. 

2. Click on the Tomcat 7.0 link in the Download column on the left of the screen. 

3. Click on the 7.0.29 link (or, if not available, most recent version) under Quick Navigation. 

4. Click on the 32-bit Windows zip link after the Core bullet under Binary Distributions.  

5. Click on Save, navigate to a suitable location (your Java SE folder?) and then click on Save again. 

(This will cause file apache-tomcat-7.0.29-windows-x86.zip (size 8.36MB) to be downloaded. 

6. Click on Open Folder.   

7. Right-click on the zip file and select the option to extract the file’s contents, saving them in the 

current location. 

8. Click on OK. This will create a sub-folder structure headed by a folder called apache-tomcat-

7.0.29-windows-x86.  

9. Rename apache-tomcat-7.0.29-windows-x86 to something shorter, such as Tomcat7. 

10. Use the Control Panel to set up the three system environment variables listed below. (If unsure how 

to do this, refer to foot of previous page, but use the New button instead of the Edit button.) 

 (i) JAVA_HOME  (Must be in upper case!) 

  This should hold the path to your Java folder. 

  E.g., C:\JavaSE7. 

 (ii)  CATALINA_HOME (Must be in upper case!) 

  This should hold the path to your Tomcat folder. 

  E.g., C:\JavaSE7\Tomcat7. 

(iii) JRE_HOME  (Must be in upper case!) 

  This should hold the path to your JRE folder. 

  E.g., C:\JavaSE7. 

11. Again accessing the environment variables, add file servlet-api.jar to your CLASSPATH variable. 

This file will be in <TomcatDir> \lib. E.g., C:\JavaSE7\Tomcat7\ lib\servlet-api.jar. 

12. Within your Tomcat folder is a folder called bin. Add the path to this folder to your PATH variable. 

 (This step gives easy access to the startup.bat and shutdown.bat files mentioned below. 

Alternatively, of course, you can move into the above folder before using the startup and shutdown 

commands.) 

13. Click on OK three times as you come out of the Control Panel. 

14. Open up a command window and enter  the following command: startup 

 Five lines of output should appear in the window and a second command window will begin to fill 

up with output. When a line commencing INFO: Server startup appears in this second window, the 

Tomcat server is running. 

15. To see information about Tomcat and to access example servlets and JSPs, open up a browser 

window and enter: 

   http://localhost:8080 

If the Tomcat Web page appears, the installation has been successful. 

16. To stop Tomcat, enter the following command: shutdown 

 (This assumes, of course, that your PATH variable has been modified as described three steps 

earlier.) 
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Java Media Framework (JMF) 
 

1. Go to http://www.oracle.com/technetwork/java/javase/tech/index-jsp-140239.html. 

2. Click on the small Download JMF link (near the bottom of the page, immediately under the 

Downloads header). 

3. Click on the Download button. 

4. Click on the radio button in the table header to accept the terms of the licence agreement. 

5. Click on the jmf-2_1_1e-windows-i586.exe link (alongside Windows Performance Pack). 

6. Click on the Save button, navigate to a suitable location for the downloaded file (which will 

probably be the top level of your drive C) and then click on Save again. (File takes up 4.97MB.) 

7. Click on Open Folder.  

8. Double-click on the .exe file. 

9. Click on Run. 

10. Click on the Yes button to accept the terms of the licence agreement and then click on Run. 

11. Follow the straightforward setup procedure, using the Browse... button to navigate to your Java SE7 

folder for the destination location and accepting all other default settings. 
12. Click on Finish to confirm that you want to restart your computer now. 
13. Successful installation will result in the following changes within your Java folder: 

 several new files in <JavaSE7>\bin; 

 new files in <JavaSE7>\lib; 

 new files in <JavaSE7>\jre\lib\ext; 

 five sub-menu options from start->All Programs->Java Media Framework 2.1.1e, 

including utilities JMF Customizer, JMF Registry and JM Studio. 
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Eclipse 

1. Go to http://download.eclipse.org/webtools/downloads. 

2. Click on the 3.4.0 link under the Build Name column of the Latest Downloads table. 

3. Click on the following link under All-in-one Packages: Eclipse IDE for Java EE Developers. 

4. Click on Windows 32 Bit alongside Eclipse IDE for Java EE Developers (the top option). 

5. Click on the large green arrow immediately below Download eclipse-jee-juno-win32.zip from:, click on the 

Save button, navigate to the desired location (probably the top level of drive C or maybe C:\JavaSE7)  and 

click on Save again. (File occupies 221MB.) 

6. Click on Open Folder. 

7. Right-click on file eclipse-jee-juno-win32.zip and then select the option to extract the contents of this zip file 

to a convenient location (possibly the top level, alongside your main Java folder, or possibly immediately 

below your Java folder, but don't create a new folder, since one entitled eclipse will be created 

automatically). If you are accepting the default location, then delete \eclipse-java-juno-SR1-win32.zip from 

the end of the path, since this will create a redundant folder level. The resultant folder structure will take up 

257MB. 

8. Right-click on the eclipse.exe file inside the eclipse folder that has now appeared, create a shortcut to it and 

then pin the icon to the taskbar. 

9. Start Eclipse running, either by single-clicking on the taskbar icon or by double-clicking on the icon for file 

eclipse.exe. 

10. When prompted by Eclipse, navigate to a suitable location (probably within your Eclipse folder or your main 

Java folder) and create a new workspace folder called Workspace. 

11. Click on OK, tick the Use this as the default and do not ask again checkbox and click on OK again. 

12. Close the Welcome window by clicking on the cross in the window's tab.  

13. Select menu Window->Preferences->General->Editors->Text Editors, making sure that Text Editors is 

highlighted. 

14. Tick/select the Show line numbers checkbox and click on OK. 

15. Select Window->Preferences->Java->Code Style->Formatter. 

16. Click on the New... button, enter a name (e.g., JavaFormat) for the profile name, select Java Conventions 

[built-in] from the drop-down list and click on OK. 

17. Select each required formatting tab in turn [See Formatting Categories and Their Settings below], make the 

required format changes and click on Apply. Do not click on OK until changes to all required formatting 

categories have been made. If OK is clicked early by mistake, then click on Edit to continue changes.  

18. Click on OK twice and continue from step 19. 



6 

Formatting Categories and Their Settings 

[Remember to click Apply, not OK, at the end of each category!] 

 

Indentation 

Tick/select Statements within 'switch' body. 

Leave all other Indentation options unchanged. 
 

Braces 

Change all options apart from the last (the Array initializer option) from Same line to Next line. 
 

White Space 

No changes. 
 

Blank Lines 

Change the number of blank lines from 1 to 0 for each of the 3 items below. 

 Before import declaration 

 Between import groups 

 Before declarations of the same kind 

Leave all other Blank Lines options unchanged. 
 

New Lines 

Tick/select at end of file. 

Leave all other New Lines options unchanged. 
 

Control Statements 

Tick/select the following options: 

 Insert new line before 'else' in an 'if' statement 

 Insert new line before 'catch'  in a 'try' statement 

 Insert new line before 'finally'  in a 'try' statement 
 

Line Wrapping 

Change Maximum line width to 65. 
 

Comments 

Change Maximum line width to 65. 
 

[Now click on OK twice.] 

19. Select Window->Preferences. 

20. Select Java->Code Style->Code Templates. 

21. Click on the '►' symbol next to Comments in the top right window. 

22. For each category under Comments (Files, Types, etc.), click on the category, click on the 

Edit… button, drag with the mouse across the whole pattern, press the Delete key (on the 

keyboard) and click on OK. 

23. Now click on the '►' symbol next to Code in the centre-most window and do the same for each 

of its categories, starting at Method body.  

24. Click on OK. 

25. Select Window->Preferences. 

26. From navigation pane on left, select Java->Installed JREs->Execution Environments. 
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27. Click on line of table that shows the path to your JRE (Java Runtime Environment), probably 

JavaSE-1.7. 

28. Tick the box that appears next to the appropriate option in the Compatible JREs column and 

then click on OK. 

29. Again select Window->Preferences and then, from the navigation pane on the left, select   

Java->Installed JREs (making sure that you click on this option to select it). 

30. Click on line of table that shows the path to your JRE. (There will probably be only one line.) 

31. Click on the Edit… button and then on Add External JARs... . 

32. Click on Add External JARs…, browse to the location of jmf.jar (JavaSE7\JMF2.1.1e\lib??), 

select jmf.jar and click on Open. 

33. Click on Finish and then on OK. 

(Steps 34-37 below get rid of an access restriction error message that versions of Eclipse from 

Galileo onwards generate when using the JMF.) 

34. Select Window->Preferences->Java->Compiler->Errors/Warnings. 

35. Click on Deprecated and restricted API to expose the associated settings. 

36. Alongside Forbidden reference (access rules):, you will see a drop-down list with Error as the 

current setting. Change this to Ignore and then click on OK. 

Though programs run in the command window will play videos without problem via the JMF, 

Eclipse requires the necessary dll files to be in a folder that is not the default folder for the JMF 

installation. Step 37 below ensures that these files are where Eclipse expects to find them. 

37. Navigate to C:\Windows\SysWOW64 and scroll down to the group of dll files that have names 

commencing with 'jm'. (You should find that there are 20 of these, all with a creation date of 

28/04/2003.) Copy these files and then paste them into C:\<JavaSE7>\jre\bin. 

38. Select File->Switch Workspace->Other... . 

39. Click on Browse... and navigate to Tomcat's webapps folder, making sure that this folder is 

selected. 

40. Click on OK and then click on OK in the next window. 

(Eclipse should close down at this point and then open up again, in order for the new workspace to 

be recognised.) 

41. This completes the setup procedure for Eclipse, so you can now either experiment with Eclipse 

or select File->Exit.  

Jan Graba 

18/7/12 
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